Author Topic: LinkStation LS210D won't BOOT UP, Flashing White (LED)  (Read 10240 times)

Adee

  • Calf
  • *
  • Posts: 4
LinkStation LS210D won't BOOT UP, Flashing White (LED)
« on: March 11, 2015, 11:22:15 am »
Hi,
i bought this link station a few days ago and its bricked outta no where,
it won't boot up, i assume,
the LED is flashing white constantly,
Tried everything to make it to work. unfortunately, i cant even return it. cuz i have bought it for my brother back in the US. Shipping it back would cost 40$.
any help would be very much appreciated, i have the firmware and TFTP client, as well putty, the only problem is that it wont get detected by my router or the NAS Navigator.
i tried to boot it into recovery mode by holding down the function key while powering it on releasing the function key and holding it back on.
doing so both the LED started flashing white, however it is still not detected by the router, PC itself, NAS Navigator or the LS Updater,

i am very much disappointed,
if any one could help i would very much appreciate,

i have the firmware update the ls updater. if i need to i could probably give a try installing Debian.
if only it could work with TFTP or Putty.

cheers

Adee

  • Calf
  • *
  • Posts: 4
Re: LinkStation LS210D won't BOOT UP, Flashing White (LED)
« Reply #1 on: March 13, 2015, 04:09:07 am »
Ok.
ended with removing the HDD deleting all the partitions in windows. recovered the data though with a flick ;p
for those who have trouble recovering data here is a very simple solution. boot the drive with PC linux live CD, the drive is not encrypted and your entire data is visible just with a simple click.
Now back to business!

The firmware on this linkstation is
VERSION=1.62-0.04
INITRD=2014/12/25 22:45:24
ROOTFS=2014/12/25 23:33:10

After wiping the entire HDD along with the partitions the linkstation now is flashing RED (7 times) reading forums its stated as RAM HDD or LAN issues (which is totally not true).
Holding down function just for a second and the Linkstation is booted into Emergency Mode (i assume as its accepting TFTP packets),
now here comes the main problem. I just checked kinda everywhere and can't find the right TFTP boot recovery software for LS210D linkstation.

To be honest i checked what was inside the package (TFTP) its just three files that's needed really.
uImage.buffalo
u-boot.buffalo
initrd.buffalo

Ok this is now the problem, all of these files are included in the firmware file, which is a good thing. a simple work around would be simply replacing them with the one from the firmware, however there is a serious problem. Buffalo changed the passwords for the image and there is no way it can be extracted without a password. Reading through a few forums i found out the passwords for the older versions. which is 1NIf_2yUOlRDpYZUVNqboRpMBoZwT4PzoUvOPUp6l  (yea i know thats a hell lot of work for a password retriever software).

So now i am stucked again. the linkstation is accepting TFTP file transfer however i don't have a valid Boot image to pass onto it.
One thing i am still very much confused about is the fact that i still can't see the link station in LS Updater, Nas Navigator or in the router DHCP client list.

The ip address maybe random but connecting it several times i get an ip 192.168.11.150 , its shown in TFTP window.

very confusing uptill now. i hope it will be fixed. finger crossed.

By the way you guys could say a hello and i think that will make me feel a little better ;p
pretty much on my own uptill now :(

cheers

ddatdd

  • Calf
  • *
  • Posts: 3
Re: LinkStation LS210D won't BOOT UP, Flashing White (LED)
« Reply #2 on: July 27, 2015, 03:48:00 pm »
I am in same problem as you, I cant send HDD for $40 to USA for replacement
and stuck in white flashing light

LS200 series tftp boot files at http://aaronhastings.me/content/buffalo_ls200/TFTP_Boot_Recovery_LS200.zip

Completely recovering from a “bricked” Buffalo LinkStation LS200-series NAS (and opening the firmware too!)
https://www.aaronhastings.me/completely-recovering-from-a-bricked-buffalo-linkstation-ls200-series-nas-and-opening-the-firmware-too/