Author Topic: LS ch 2.0  (Read 4489 times)


  • Calf
  • *
  • Posts: 1
LS ch 2.0
« on: November 19, 2013, 07:03:48 pm »
I have had a Buffalo Nas for a while now and now and again I run into issue.  I received a red light the other day after researching I figure I needed to update my firmware.  After updating my firmware I went from the red light to the blue EM mode light.  I had this issues before but I do not remember how I got out of the em mode.  Can someone give me some advise?


  • Calf
  • *
  • Posts: 1
Re: LS ch 2.0
« Reply #1 on: March 03, 2014, 04:20:13 am »
I have also recently come across this problem and cannot find any step by step guidelines.
I like you went into Emergency mode and the fault indicated that i need to upgrade firmware or contact tech support. I tried to update firmware using LSUPDATER.exe but it isnt recognising the drive.

Any info would be gratefully recieved. Does anyone know if i will loose all the data on a the drive or it is recoverable???

many thanks

Many Thanks

Jim Reed