Author Topic: WBR2-G54 - NAT/XBOX issues  (Read 10151 times)

juicy_g

  • Calf
  • *
  • Posts: 5
WBR2-G54 - NAT/XBOX issues
« on: December 20, 2009, 11:30:59 am »
   

I have a WBR2-G54 buffalo airstation router. I recently bought an XBOX 360 Elite. But whenever i play Halo 3, it gives me the message my NAT is STRICT. This problem also prevents me to join party chats and game invites from my friends. So i looked online to find a solution. It tells me i have to open my UDP and TCP ports. 3074, 88 and such. It took me a while to figure out how to get to my router settings but i did it. I went to applications>internet games. Then it asks for the TCP Port/UDP Port/LAN IP. Then i enter 3074 into both TCP and UDP because that is what it requires. Then my IP. I have to enter the correct IP or it won't make the changes, so basically i know i am entering the correct IP. In the end...my XBOX NAT is still on STRICT. I am quite frustrated and i really need a solution.

 

Is there anything i can do?

Am i doing something wrong?

Did i forget to add something?

 

 

Please help!


Colin137

  • Big Bull
  • *****
  • Posts: 1125
Re: WBR2-G54 - NAT/XBOX issues
« Reply #1 on: December 21, 2009, 05:07:22 pm »

You need to forward ports UDP 88 and TCP/UDP 3074 to the IP address of the xbox. PM me with the WAN IP address of the buffalo router.


Colin137

  • Big Bull
  • *****
  • Posts: 1125
Re: WBR2-G54 - NAT/XBOX issues
« Reply #2 on: December 22, 2009, 02:51:53 pm »

Please don't PM me with questions. Ask them in the thread, so everyone can benefit from the question and answer. I rarely check my PMs unless I'm expecting one.

 

juicy_g's question was "Where do I find my WAN IP".

 

To find the WAN IP address in the WBR-series routers, log in to the web interface, click on Advanced, then Management. This will display a table of system information. Look at the WAN Settings section, your WAN IP Address will be listed.


Colin137

  • Big Bull
  • *****
  • Posts: 1125
Re: WBR2-G54 - NAT/XBOX issues
« Reply #3 on: December 22, 2009, 06:32:27 pm »

...and don't post WAN IP addresses in the forum, as that's a security risk, hence my asking you to PM the IP address to me. I deleted your post to minimize the impact of that information.

 

The IP address you provided was a public address, given to your router by your ISP, so the port forwarding should work fine.

 

When you set up port forwarding, make sure you are entering the IP address of the Xbox 360. You can check the IP address of the 360 in it's network settings. That's most likely the problem you're encountering.


juicy_g

  • Calf
  • *
  • Posts: 5
Re: WBR2-G54 - NAT/XBOX issues
« Reply #4 on: December 22, 2009, 06:51:06 pm »
   

ahh thanks!

 

So could you tell me step by step what i should do? I am a complete beginner at these networking things


Colin137

  • Big Bull
  • *****
  • Posts: 1125
Re: WBR2-G54 - NAT/XBOX issues
« Reply #5 on: December 22, 2009, 09:40:55 pm »

First, find out the IP address of the Xbox 360.

 

Then log in to the web interface of the router, click on Advanced, then Network Settings->Address Translation. At the bottom, you'll see the NAT table. Delete any entries in that table before continuing.

 

Click Enter NAT Table. Select New Group, and name the group XBL for Xbox Live. Then use the following settings:

 

IP Address of WAN: leave on Airstation's WAN IP address.

Protocol (WAN): TCP/UDP. select either TCP/UDP, and enter the port number.

IP Address of LAN: set to the IP address of the xbox 360

Protocol (LAN): leave this field blank.

 

Create a new nat table entry for each port: UDP 88, TCP 3074, and UDP 3074.


juicy_g

  • Calf
  • *
  • Posts: 5
Re: WBR2-G54 - NAT/XBOX issues
« Reply #6 on: December 22, 2009, 10:02:17 pm »
   

 

 

 

After entering that...This pops up

 

Item: Address Change Table Addition -- LAN Side IP Address
Details: Out of network address range.
Configuration Error. Try again


Colin137

  • Big Bull
  • *****
  • Posts: 1125
Re: WBR2-G54 - NAT/XBOX issues
« Reply #7 on: December 22, 2009, 10:10:16 pm »

That error means that your Xbox's IP address is not in the range of IP address passed out by the router. This is most likely due to your Xbox not being connected to the Buffalo router. Check to make sure your connecting to the correct network.


juicy_g

  • Calf
  • *
  • Posts: 5
Re: WBR2-G54 - NAT/XBOX issues
« Reply #8 on: December 22, 2009, 10:14:30 pm »
   

Alright so my Buffalo router is by my desktop outside. I have this 30-40ft ethernet cable that comes into my room and connects into another router(non wireless router). The buffalo router and this other router are connected with that 30-40ft cable. Then from that other router, i have an ethernet cable that connects to the xbox. I have that 2nd router because i use it for my laptop in my room. So what i am saying is, the xbox is somewhat connected to the buffalo one.


Colin137

  • Big Bull
  • *****
  • Posts: 1125
Re: WBR2-G54 - NAT/XBOX issues
« Reply #9 on: December 22, 2009, 10:22:44 pm »

Your best bet for a setup like that would be to disable the routing functions of the 2nd router (i'm assuming it's a Linksys based on the IP address you gave for the Xbox). To do this, disable the DHCP server on the 2nd router, and hook it all up with the LAN ports. Don't use the WAN/Internet port on the 2nd router. If that doesn't work, call the 2nd router's manufacturer and ask them to help you bridge the router, or set it up as an access point.

 

The problem is that the 2nd router also has a firewall in it. In order to do the port forwarding without bridging the 2nd router, you would have to forward ports on the buffalo to the IP of the 2nd router, then forward ports in the 2nd router to the IP of the Xbox. That's pretty convoluted, and you'll suffer a performance hit because of it. I strongly recommend bridging the 2nd router.


juicy_g

  • Calf
  • *
  • Posts: 5
Re: WBR2-G54 - NAT/XBOX issues
« Reply #10 on: December 22, 2009, 10:36:43 pm »
   

ahhh I never even thought of doing this but i just put the 30-40ft ethernet cable directly into the xbox and it surprisingly works...No more Strict NAT messages.

You know what...the 2nd router was probably the problem.

 

My problem has been solved. Many thanks to you for taking your time to help me. You were a great help, i have learned a bit from this.

 

THANK YOU!