Author Topic: Is the WLI-UC-G300N compatible with Vista 64bit?  (Read 5961 times)

shift_refresh

  • Calf
  • *
  • Posts: 2
Is the WLI-UC-G300N compatible with Vista 64bit?
« on: February 17, 2009, 12:18:22 am »
   

Hi,

 

Does anyone know if the Nfiniti™ Wireless-N Compact USB 2.0 Adapter WLI-UC-G300N is compatible with Windows Vista Ultimate (64 bit)?

 

The product specifications says it is Vista (32bit) compatible, but there is no mention of 64bit. I'm upgrading machines next week and want to make sure I'll still be able to connect with it! It may work fine, I'm not sure, or perhaps there are 64bit drivers?

 

Any information would be greatly appreicated.

 

Thanks,

Lee.

 


Darkwing

  • Calf
  • *
  • Posts: 14
Re: Is the WLI-UC-G300N compatible with Vista 64bit?
« Reply #1 on: February 17, 2009, 10:54:14 am »
   

Hi,

 

I managed to get it working under windows vista ultimate 64 bit. No thanks to Buffalo though, as they don't do 64 bit...lol.

 

You can download 64 bit drivers from the Ralink website http://www.ralinktech.com/ralink/Home/Support/Windows.html

 

I used the first driver.

 

Cheers


shift_refresh

  • Calf
  • *
  • Posts: 2
Re: Is the WLI-UC-G300N compatible with Vista 64bit?
« Reply #2 on: February 17, 2009, 04:05:32 pm »
   

Cheers for that mate. I shall download in preperation for my new machine (can't wait!)

 

Is there any trick to it, or is it simply a matter of installing the drivers, then installing the adapter?

 

Thanks :


Darkwing

  • Calf
  • *
  • Posts: 14
Re: Is the WLI-UC-G300N compatible with Vista 64bit?
« Reply #3 on: February 26, 2009, 07:43:52 am »
   

Just install the drivers, and then you need to manually install the stick. Click don't install automatic but search for drivers. Then you'll get a list of manufacturors, select buffalo and then wirelessN I thought.

 

Good luck.


04payot

  • Calf
  • *
  • Posts: 1
Re: Is the WLI-UC-G300N compatible with Vista 64bit?
« Reply #4 on: June 06, 2009, 06:48:14 am »
   did wli-uc-g300n worked in vista 64bit using the ralink website?and please tell which one you clicked to make wli-us-g300n work?