Author Topic: CentOS + WLI-UC-G300HP USB WIFI  (Read 5785 times)

Bas-Man

  • Calf
  • *
  • Posts: 5
CentOS + WLI-UC-G300HP USB WIFI
« on: May 11, 2009, 01:31:40 am »
   

Hi Guys,

I have done some searching through the forum, but not come across anything that might help me yet.

 

I have been trying to get my CentOS 5.3 to work with the WLI-UC-G300HP USB Wifi dongle.

 

I tried using ndiswrapper with a number of the windows drivers that came with stick, but either they do not detect the dongle or, in the one case, detects the dongle, but then causes the kernel to panic when I try to bring the interface up. I also tried RaLinks RT2870STA drivers, as this was meant to work with the WLI-CU-G300N but this sadly had no luck, not much of a hardware programmer, but guessing that the card is not listed in the list of working USB sticks in the source code based on my looking around. The WLI-UC-G300N had been added in the lastest version of the driver I downloaded.

 

Wondering if anyone else has tried using this dongle with linux and if they had had any success. Pointers to config and drivers would be great.


Bas-Man

  • Calf
  • *
  • Posts: 5
Re: CentOS + WLI-UC-G300HP USB WIFI
« Reply #1 on: May 17, 2009, 01:05:53 am »
   

Just a note that does driver (RaLinks RT2870STA)  does actually work.

 

I will post back more details in a bit. 

 

Whist it does appear to work, I am seeing some issues where the packets are not being sent or received.

I noticed a long thread on firmware, so I need to check my router firmware I guess.

Message Edited by Bas-Man on 05-17-2009 03:06 PM

Bas-Man

  • Calf
  • *
  • Posts: 5
Re: CentOS + WLI-UC-G300HP USB WIFI
« Reply #2 on: May 17, 2009, 07:11:44 am »
   

Thought it might be time to post the solution.

 

Basically I came across this link

 

http://www.wireless-driver.com/download/buffalo/Buffalo-Nfiniti-Wireless-N-High-Power-Compact-USB-20-Adapter-WLI-UC-G300HP-Drivers.htm

 

Which states:

Device Name: BUFFALO WLI-UC-G300HP Wireless LAN Adapter, it's based on Ralink RT2870 series USB  Wireless LAN Card.

Hardware ID:  USB\VID_0411&PID_0148

 

So I decided I would try the RT2870STA Driver again

 

I downloaded the latest version from http://www.ralinktech.com/ralink/Home/Support/Linux.html

 

Specifically http://www.ralinktech.com.tw/data/drivers/2009_0424_RT2870_Linux_STA_V2.1.1.0.tgz

 

I downloaded and moved this file to /usr/src

 

I based my solution on this page http://ubuntuforums.org/showthread.php?t=960642

 

I followed the basic steps. 

 

unpack the tar file

 

1) cd 2009_0424_RT2870_Linux_STA_V2.1.1.0/

2) cd 2009_0424_RT2870_Linux_STA_V2.1.1.0/os/linux

3) vi usb_main_dev.c

4) add {USB_DEVICE(0x0411,0x0148)}, to the list of devices, you can find this by searching for "Buffalo" and adding the above line under that last entry.

 

So it shoud look like

 

        {USB_DEVICE(0x0411,0x00e8)}, /* Buffalo WLI-UC-G300N*/
        {USB_DEVICE(0x0411,0x0148)},

 

5) cd /../..

6) make

7) make install

8) modprobe rt2870sta

 

You should now see ra0 as an interface  when you use the iwconfig command

 

The rest is pretty standard and you should be able to find the information you need to get the interface up and running.

 

I think the driver still needs to be updated to match the hardware better, based on observation, but it works.