Author Topic: Problem adding share permissions?  (Read 3846 times)

audiodept

  • Calf
  • *
  • Posts: 10
Problem adding share permissions?
« on: September 24, 2009, 03:46:40 pm »
   

Hello all,

 

I just received my LinkStation LS - XHL today, and I'm having a bit of a problem setting it up.

 

First off, the NASNavigator application opens fine.  It displays my drive fine.  However, when I try to click Open Web.. nothing happens.  Same by trying to navigate to it through the configure menu.  Any ideas?

 

I can, however, access the Web interface via the IP address in the browser address bar.  Log in, set up a folder, fine.  When  I go to add Access Permissions, the drop down menu comes up, and I click 'Add User/Group'.  The screen at this point goes a shade of grey (as if thinking) and stays that way.  By refreshing the page, I can get access to the shares tab, but I can't seem to add any permissions. 

 

Any thoughts?

 

 

BTW im running this on a Mac OS 10.5.7 and accessing through Firefox 3.5.3

 

 

Thanks!


PCPiranha

  • Big Bull
  • *****
  • Posts: 2209
Re: Problem adding share permissions?
« Reply #1 on: September 24, 2009, 03:51:24 pm »
What firmware are you running?  I would try updating it, if it's already up to date try forcing the update.

audiodept

  • Calf
  • *
  • Posts: 10
Re: Problem adding share permissions?
« Reply #2 on: September 24, 2009, 03:51:54 pm »
   Also, my firmware version is 1.03, if that helps...

audiodept

  • Calf
  • *
  • Posts: 10
Re: Problem adding share permissions?
« Reply #3 on: September 24, 2009, 03:53:26 pm »
   I thought of that, but it appears there are no firmware updates for Mac for this unit...

PCPiranha

  • Big Bull
  • *****
  • Posts: 2209
Re: Problem adding share permissions?
« Reply #4 on: September 24, 2009, 03:59:20 pm »
Unfortunately we make firmware updae for windows computers before making them for Mac, do you have a friend or relative that has a windows computer you can use?  If not try force updating the same firmware from your mac.

audiodept

  • Calf
  • *
  • Posts: 10
Re: Problem adding share permissions?
« Reply #5 on: September 24, 2009, 04:02:23 pm »
   I have a windows computer at home I'll have to bring in (this is a work NAS).  Thanks for the hint.  I'll see how that goes for us...

audiodept

  • Calf
  • *
  • Posts: 10
Re: Problem adding share permissions?
« Reply #6 on: September 24, 2009, 04:44:33 pm »
   

UPDATE::

 

Firmware 1.10

 

Still doing it.  Any other suggestions?  I don't want to have to return the unit right out of the box....


PCPiranha

  • Big Bull
  • *****
  • Posts: 2209
Re: Problem adding share permissions?
« Reply #7 on: September 24, 2009, 08:15:27 pm »
Update to the latest version of the nasnavi.  Also try a different web browser (like safari or camino)

audiodept

  • Calf
  • *
  • Posts: 10
Re: Problem adding share permissions?
« Reply #8 on: September 24, 2009, 08:52:59 pm »
   

Thanks.  I just upgraded to version 2.20 (from 2.14)

 

I'll see if that and/or the browser swap works in the morning when I get back to work.


audiodept

  • Calf
  • *
  • Posts: 10
Re: Problem adding share permissions?
« Reply #9 on: September 25, 2009, 11:21:44 am »
   

UPDATE::

 

I'm able to add users now, which is awesome.  But they show up as 'Read Only' and I can't seem to find a way to change that...

 

 

Something simple I'm missing?


audiodept

  • Calf
  • *
  • Posts: 10
Re: Problem adding share permissions?
« Reply #10 on: September 25, 2009, 03:40:37 pm »
   

UPDATE::

 

 

Problem has been solved (somewhat)

 

I was able to assign permissions and get the system configured properly by remoting into our scheduling PC server and using the Web Interface there.  

 

 

I'll say, while the user interface is nice, it's really not Mac-friendly by any means.  

 

Problems in Mac:

 

Firefox will not let me add users

Safari will, but won't let me set permissions

Camino reacts the same as Safari

 

 

Best bet is to use a PC, although that's not really how it should be....

 

 

Thanks for all your help, though!

 

 

Best,

Mark