Author Topic: Linkstation Live: USB Drive proving to be a problematic backup destination.  (Read 6681 times)

taillessmonkey

  • Calf
  • *
  • Posts: 6
   

I have been trying to get my backup to USB drive running consistently for a month now and could really use some input.

 

I formatted it as XFS and the backup job runs forever...literally, I had to reset the linkstation.

 

Finally the USB drive just stopped showing up.  I had to plug the USB drive into a Windows machine and remove the partition, then reformat it on the Linkstation to make it show up again.

 

Tried this a few times before I formatted it with Fat32.  The backup ran with errors, but all the files were successully copied over.

 

Problem now is, the USB drive disappears at random.  I can reboot the Linkstation and it comes back up.

 

Could there be a compability issue with my USB drive enclosure? 

 

I'm willing to try whatever.  I just need to get it working.


Paul

  • Big Bull
  • *****
  • Posts: 1223

First I would flash the firmware on the unit, If you are running the latest then force it with the directions on the link below

http://forums.buffalotech.com/buffalo/board/message?board.id=0101&message.id=277&query.id=9631#M277

 

After this is complete reset the unit back to factory defaults, using the web interface under maintenance.

Then format the drive into XFS and try running a back up job again. 


taillessmonkey

  • Calf
  • *
  • Posts: 6
   

I did as you suggested: forced a flash, and reset defaults, then formatted with XFS.  Still got an error during backup.  I tried to backup 1 share which was 41 GB.  After the backup error'd out, there are 26 GB used on the target drive.

This files that did make it over are not showing up.  Windows explorer shows 0 files, despite the fact that 26 GB are being used.

 

Here are some of the errors in the log:

sync: recv_generator: mkdir "/mnt/usbdisk1/_backups/mig" failed: Input/output error (5)

rsync: recv_generator: mkdir "/mnt/usbdisk1/_backups/mig/music" failed: Input/output error (5)

rsync: recv_generator: failed to stat "/mnt/usbdisk1/_backups/mig/music/songs/The Sea and Cake/Everybody/08 Introducing.mp3": Input/output error (5)

 


taillessmonkey

  • Calf
  • *
  • Posts: 6
   

 I am going to try buying another USB drive enclosure to see if that helps.  Can anyone make any suggestions as to what I should look for?  Any particular models that have been proven successful backup destinations?

 

Any input is appreciated.

 

My current enclosure has no power source aside from what it draws from the USB port.  I see that many have AC adapters.  Could that be the issue?


taillessmonkey

  • Calf
  • *
  • Posts: 6
   

Success!  It was the backup destination's drive enclosure after all.  I bought a new one and it worked.

 

For the record, here is what worked for me:

Macally G-S350SUA Hi-Speed e-Sata/FireWire/USB2.0 Storage Enclosure

 

Here is what DID NOT work:

Eagle Tech ET-CSNSU2-BK 3.5" SATA to USB

Message Edited by taillessmonkey on 10-30-2008 01:04 PM

nstern732

  • Calf
  • *
  • Posts: 1
   Formatting the external drive as a FAT32 drive limits the size of the file you can backup. That is probably why you got errors.