Author Topic: File rename issue with Vista and LinkStation Pro Duo  (Read 6764 times)

Edin

  • Calf
  • *
  • Posts: 14
File rename issue with Vista and LinkStation Pro Duo
« on: October 06, 2008, 09:14:47 pm »
   

I have a strange problem.  Windows XP Pro works flawlessly with NAS, something I cannot say for Vista Business.  I can access shared folders, map drives, create or delete files/folders, copy, cut, paste...  but cannot RENAME anything... even when I disable share protection.  When I try to rename file or folder, it gives me following message:

 

"The U:\ folder does not exist.  The file may have been moved or deleted.

Do you want to create it?"

 

If I click "yes", the message comes back, as many times as I click "Yes".  If I click "No", the message goes away, and file/folder keep the same name.

This is a big problem, because most of backup programs, including included Memeo, SyncToy, etc., would not work.  They all need to rename log files, and they all fail to complete.

I installed the "File Security Tool", and also made the change to Local Security Policy, as specified in this forum and knowladge base.  Nothing works.

 

Please help.


Edin

  • Calf
  • *
  • Posts: 14
Re: File rename issue with Vista and LinkStation Pro Duo
« Reply #1 on: October 07, 2008, 07:33:52 am »
   

Resolved...

 

For those who may run into the same:

  • Make sure your Vista logon account matches one on your NAS (user name, password, workgroup).
  • Remove all map drives you made to NAS.
  • Disable offline files.
  • Remove all cached credentials, stored passwords.
  • Rebood and re-map your drives.

 

Once again, Vista proved to be a pain in a rear end.  Spent 3 hours fighting with it last night, and finaly got it.  Memeo and SyncToy is now working OK.


herrerajosea

  • Calf
  • *
  • Posts: 3
Re: File rename issue with Vista and LinkStation Pro Duo
« Reply #2 on: February 13, 2009, 10:27:08 am »
   

This solution didn't work for me. Where do you disable offline files, clear password cache.

 

I matched my vista logon and NAS accounts (username, pass, wkgroup) - removed drives - rebooted - then remapped drives with NAS utility thingy and manually - but still cannot rename folders on drive.

 

I have the LinkStation Pro (not Duo) I'm assuming it should be the same as far as this issue is concerned.?

 

Any help would be appreciated - the only solution i can come up with is to copy entire directories off my desktop onto my mapped drive.

 

 


lake12nj

  • Calf
  • *
  • Posts: 1
Re: File rename issue with Vista and LinkStation Pro Duo
« Reply #3 on: February 26, 2009, 02:48:40 pm »
   I had the same issue with not being able to name or rename folders on the NAS from my notebook running vista 64 bit and the key for me was just to disable offline files by going to the control panel -> classic view -> Offline files -> disable offline files then reboot the machine. Everything works fine now. Hope this helps.

herrerajosea

  • Calf
  • *
  • Posts: 3
Re: File rename issue with Vista and LinkStation Pro Duo
« Reply #4 on: March 29, 2009, 03:30:33 pm »
   

No luck still. My Offline files were already disabled. The local account on my NAS matches my local account for my Vista OS - name and password are the same. I've removed networked drives, rebooted, then reconnected drives using the Vista OS credentials. No luck - still I'm not able to rename/name folders.

Any other ideas? Anything else I need to 'clear' out or a setting I should check?

Weird thing if I use Ubuntu and connect to the drive I'm able to make all changes to files/folders with no problem at all - no need to map drives or anything.

Please help.


herrerajosea

  • Calf
  • *
  • Posts: 3
Re: File rename issue with Vista and LinkStation Pro Duo
« Reply #5 on: March 30, 2009, 08:04:56 am »
   

I found the solution! I tried everything above but nothing worked. So i found this article over at microsoft.com:

 

http://support.microsoft.com/kb/934160

I updated the registry as it suggested and presto! I can now change folders and files names.

 


Dustrega

  • Big Bull
  • *****
  • Posts: 1394
Re: File rename issue with Vista and LinkStation Pro Duo
« Reply #6 on: March 30, 2009, 11:45:48 am »

Good call and the download is also available on our website:

 

http://www.buffalotech.com/support/getfile/?Buffalo_NAS_Vista_Support.zip

 

or you can take the fast track and get it here.

Message Edited by Dustrega on 04-02-2009 12:56 AM