Author Topic: HELP: LS Live V2, stock firmware, suddenly ran into EM mode, but never get out of it.  (Read 3900 times)

elale

  • Calf
  • *
  • Posts: 6
   I've just got a problem: LS Live V2, worked well for 1.5 years, suddenly ran into EM mode, and never get out of it.

It can get IP from my DHCP server, and LSUpdater can find it with following info:
HOST="HS-DHGL-EM3D3"
WORKGROUP = "UNKNOWN"
IP-address = "192.168.1.138"
Firmware Ver = "----"

but cannot flash a new firmware. The error message is:
Couldn't confirm a response from HS-DHGL-EM3D3.
please check a network address of both PC and HS-DHGL-EM3D3.
Please disable the Firewall function if it is working on PC.
Updating is aborted



First of all, I made sure that was not network problem (PC and LS).

I then used acp_commander.jar and gained access to the box. I followed what I could find in the some forums, but I failed all the time :smileysad:

0) Initially in EM mode, the /boot is mounted with /dev/ls_disk1_1, changed it with /dev/sda1 (seems the same one), did not work.


1) checked /boot folder, did not find file "hddrootmode", nor "rootfs_ok". Then created them, and they DID exist after reboot, but LS did not work.

 

2) mount /dev/sda2 /rootfs, checked /rootfs/etc, there's no file "*booting*". But there's neither "linkstation_release", nor "linkstation_emergence", created these "linkstation*" files. Did not work.


3) checked /boot/boot_options, and the statement "MENU_TIMEOUT=4" is just what is expected.

 

4) the HDD seems OK, since I've successfully mounted /dev/sda1, sda2 sda6, and even list the contents of some files. I also checked them use fsck, no error messages.

 

5) Also tried TFTP appraoch: followed the instructions listed in http://buffalo.nas-central.org/index.php/Revive_your_arm9_box_from_scratch, downloaded the software from ftp://24.153.165.234/disk1/share/nas-recovery/, installed TFTP server, setting my PC's ip to 192.168.11.1. Though I can ping LS box (192.168.11.150), but the tftp server cannot get any TFTP request.


I'm now stuck here and cannot access the files in LS pro box any longer.

 

Anything else I should check or perform? Any suggestions/hints are highly appreciated. Thanks.

-elale

Message Edited by elale on 01-31-2009 09:20 AM
Message Edited by elale on 01-31-2009 09:21 AM

Dustrega

  • Big Bull
  • *****
  • Posts: 1394

elale,

 

   I noticed that you mentioned this device in the tag as being a LS Live but you mention in your post that:


elale wrote:
I'm now stuck here and cannot access the files in LS pro box any longer.
   

   Can you specify the model number of the device for me (should be on the bottom or back of the unit)?  This way I can assure you're downloading the correct firmware.

 

Message Edited by Dustrega on 01-31-2009 06:11 PM

elale

  • Calf
  • *
  • Posts: 6
   

Sorry, it's LS Live v2, HOST="HS-DHGL-EM3D3" (this is EM mode), normal name is HS-DH500GL, not LS Pro. I've used firmware "HS-DHGL_206_013_us" downloaded from buffalotech site.

 

Message Edited by elale on 01-31-2009 07:48 PM

elale

  • Calf
  • *
  • Posts: 6
   
Finally my LS box comes back to work. I'm not quite sure which approach actually took effect since I combined several together:

+) Download newer firmware version for LS Live v2, namely 2.11
+) Change my vista machine to a XP one.
+) Change the switch (without enabling DHCP) to a cross-over cable.

I used the LSUpdater.exe to find and flash the new firmware. Everything seems OK now, except for several weird things: Fan does not work, nor the power button, but the reset button now acts like power button. Maybe I'll fork a new thread for discussing this.
Thanks a lot!
-elale
Message Edited by elale on 02-01-2009 10:17 AM