Author Topic: LinkStation Live (LS-CHL) firmware update aborts  (Read 13067 times)

jimmis

  • Calf
  • *
  • Posts: 5
LinkStation Live (LS-CHL) firmware update aborts
« on: January 18, 2009, 07:29:56 am »
   

Yesterday I got the 1 TB version of the LinkStation Live and I've been trying to update the firmware without any success. The firmware I'm trying to update to is v1.06 that's available here:

http://www.buffalo-technology.com/support/downloads/linkstation-live-with-bittorrent/

 

Here's how the procedure is going for me:

1. Start LSUpdater application, it locates the LS Live device at 192.168.0.1

2. Select the force update from the Debug menu and click OK

3. Click the update button on the app and after a progress bar I am greeted with:

 

Couldn't confirm a response from LS.

 

please check a network address of both PC and LS

 

Please disable the Firewall function if it is working on PC.

 

Updating is aborted.

 

 

The LSUpdater.ini file is now looking like this:

[Application]
Title = BUFFALO LS-CHL Updater Ver.1.06
WaitReboot = 480
WaitFormat = 500

[Target]
ProductID = 0x00000010
Name = LS-CHL

[Flags]
VersionCheck = 0

[SpecialFlags]
Debug = 1

 

If I log on to the Web interface of the LS it is telling me the following system info:

LinkStation Name LS

LinkStation Description LinkStation Live II

Model Name LS-CHL

Firmware Version 1.01

Current Date and Time 2009/1/18 15:14:10
Time Zone GMT+02:00
Windows Network Workgroup NameWORKGROUP
AppleTalk FunctionDisabled
AppleShare Network Zone Settings
FTP Server Function Enabled
NTP Function Disabled
Email Alert Notification Disabled
Fan Status Normal
.
Any ideas why the firmware update is not working? There is no firewall running on the PC (OS: Windows XP) and the device installation wizard on the CD completes successfully. The device is directly connected to the PC via an RJ45 crossover cable.

sorethumbs

  • Calf
  • *
  • Posts: 18
Re: LinkStation Live (LS-CHL) firmware update aborts
« Reply #1 on: January 18, 2009, 07:34:27 am »
   

I was going to go for that firmware but its the US one and i thought i better stick to 1.02 on the UK downloads

 

Not sure what difference is in them but few things i seen have said not to get it from outside your own region

 

Whether that right or not i'm not sure, have you tried the 1.02 first to see if that works


jimmis

  • Calf
  • *
  • Posts: 5
Re: LinkStation Live (LS-CHL) firmware update aborts
« Reply #2 on: January 18, 2009, 08:57:42 am »
   

Are you sure that is the US firmware? I arrived at that download link by first selecting the Europe region on the Buffalo site and then navigating to the LinkStation Live w/ BitTorrent downloads. That v1.06 firmware download seems to have been put online yesterday.

 

I suppose I should try out the v1.02 firmware aswell if I can update atleast to that one.


sorethumbs

  • Calf
  • *
  • Posts: 18
Re: LinkStation Live (LS-CHL) firmware update aborts
« Reply #3 on: January 18, 2009, 09:28:19 am »
   

Quite right - my apologies like you say must have put it there yesterday

 

Well in that case i'm not sure, perhaps a few others will try it and post their results

 

I might try later i'm in middle of a big transfer at minute


jimmis

  • Calf
  • *
  • Posts: 5
Re: LinkStation Live (LS-CHL) firmware update aborts
« Reply #4 on: January 18, 2009, 09:58:38 am »
   I tried the v1.02 firmware and I'm getting the same result with that one aswell. I am running out of ideas. It seems that the device just cannot be updated.

jimmis

  • Calf
  • *
  • Posts: 5
Re: LinkStation Live (LS-CHL) firmware update aborts
« Reply #5 on: January 18, 2009, 10:36:20 am »
   

Just did a quick test and downloaded the v1.06 firmware by following the US region links on the Buffalo site and surprise surprise the US and EU version download files are identical.

 

This makes sense from the production point of view but what is this nonsense about warranty being void if a wrong region firmware is installed :)

 

Anyway... I'm still unable to update the firmware on my LS :(


jimmis

  • Calf
  • *
  • Posts: 5
Re: LinkStation Live (LS-CHL) firmware update aborts
« Reply #6 on: January 18, 2009, 12:49:42 pm »
   

Ok.. Decided to try this once more on another Windows XP PC and what do you know.. It works.. So now I've got fw 1.06-064 succesfully updated.

 

Here's the difference between the two PCs I used:

 

1. HP laptop running Windows XP Home Edition version 2002 with Service Pack 3, Swedish language (cannot update the device)

2. An old desktop PC running Windows XP Professional version 2002, English language (no problems updating the device)

 

- also the language selection in the Buffalo Web control (Windows Client Language) has been "CP437 United States, Canada" all the time.

 

Could it really be that the firmware update fails if the Windows Client Language does not match the actual language of the Windows installation? Sounds quite strange if that is the case..