Author Topic: Can not set up web access  (Read 4654 times)

hdude

  • Calf
  • *
  • Posts: 10
Can not set up web access
« on: December 30, 2008, 09:58:10 pm »
   

No matter what I try, I cannot get this to set up properly.

 

I try UPnP but that doesn't work (even though my router, D-Link DIR-625, supposedly supports it).

 

So I try the settings manually.  I disable Auto-Configure Firewall (UPnP) on the NAS and enter port 9000 as the external port.  And in the router setup I point to the IP address of the NAS and to port 9000.  But it just does not work.  This is the error message that I get.  Error accessing BuffaloNas.com, check internet settings.  What internet settings?  I wanted to post screen shots of my settings but apparently there is no way to do that.  Please help!

 

 


hdude

  • Calf
  • *
  • Posts: 10
Re: Can not set up web access
« Reply #1 on: December 31, 2008, 09:36:20 am »
   

I was hoping someone would have some thoughts on this.  I'll give more detail.

 

NAS Setup:

 

Web Access Service - Enable

HTTPS/SSL Encryption - disable

Use BuffaloNAS.com - enable

BuffaloNAS.com Name - whatever I choose

BuffaloNAS.com Key - whatever I choose

DNS Hostname - leave blank

Auto-Configure Firewall (UPnP) - Off

External Port - 9000

 

Router setup:

 

There are two ways I can do this.  One is via Port Forwarding (which can open multiple ports) and the other is via Virtual Server (which will open one port).

 

If I try this in Port Forwarding, this is my setup:

 

Name - LS-CHLxxx (xxx indicates last three digits of MAC address and is part of the name)

IP Address - 192.168.0.2 (this is the IP address of the NAS)

Ports to open - TCP - 9000

                     UDP - 9000

Schedule - always

Inbound filter - allow all

 

If I try this in Virtual Server, this is the setup:

 

Name - LS-CHLxxx

IP Address - 192.168.0.2

Port - Public - 9000

         Private - 9000

Traffic Type - Protocol - Allows choice of TCP, UDP, Both, or other (don't know which to pick)

                   Port - Only allows three digit numer.  If I select TCP it defaults to 6

                                                                     If I select UDP it defaults to 17

                                                                     If I select Both it defaults to 257

                                                                     If I select Other it defaults to 257 and then the Public and Private ports shown above are grayed out.  

 

 

Does anyone have ANY ideas on what I need to do here?  

 

 

 

 

 


hdude

  • Calf
  • *
  • Posts: 10
Re: Can not set up web access
« Reply #2 on: December 31, 2008, 10:18:38 am »
   

THIS IS DRIVING ME ABSOLUTELY CRAZY!!!

 

 

No matter what I try this is the error message I get is...

 

Error accessing BuffaloNas.com, check internet settings.

 

 

If I use UPnP (which should work because my router supports it), this is the message that I get...

 

UPnP Gateway not found and/or doesn't support port forwarding, use manual setup.

 

 

I am about to throw something against the wall.  Problem is I don't know if it should be the router or the NAS.


Paul

  • Big Bull
  • *****
  • Posts: 1223
Re: Can not set up web access
« Reply #3 on: January 01, 2009, 01:24:03 pm »

you can test your ports first, open a browser and type your WAN IP then : 9000 "24.65.43.141:900" for example.  If this does not take you to your unit then the router is not opening the port (this would cause this error message)

 

Web Access Setup


hdude

  • Calf
  • *
  • Posts: 10
Re: Can not set up web access
« Reply #4 on: January 01, 2009, 03:47:27 pm »
   

This is what I did, thanks to this post from another forum.  This solved the problem.

 

"I looked at my Network settings, and found that my default gateway, primary and secondary DNS server settings were blank. So, I entered the ip address of my router into the default gateway and primary DNS address, and put in 208.67.222.222 (which is OpenDNS) for the secondary DNS settings. Tried it again, and it prompted me for a user id and password!

Next step was to create a new user in User Management, then Web Access -> Folders Setup and set Web Access Settings to Allow All Groups / Users

After that, went to Shared Folders -> Shared Folders Setup. Clicked my "share" shared folder, and set Access Restrictions to Enable. Then below that, moved my new user from the right side over to the read only side.

BTW, under Web Access -> Service Setup, I have the first 3 options enabled, BuffaloNAS.com Name and Key entered, and Auto-Configure Firewall on."

 

The only difference is that I had to turn Auto-configure firewall off and enter port 9000.  So now everything is working!  Of course I have not tried it outside my network yet.