Author Topic: Can't Web Access Linkstation Live through Internet  (Read 11615 times)

Ketan

  • Calf
  • *
  • Posts: 2
Can't Web Access Linkstation Live through Internet
« on: March 26, 2009, 06:59:08 am »
   

Hi,

 

I have recently purchased  Buffalo Linkstation Live (LS-CH 1TB) NAS drive. I am trying to access the web folder via internet using www.buffalonas.com service.

 

I have correctly configured my NAS drive for web access and I am able to do so via LAN (hav setup the web access port to 9000 as advised). I have also allowed relevant port forwarding on my Netgear Router to Local IP Address of my NAS Drive (In fact I have setup the Drive in DMZ of my Router so that all port forwarding is done).

 

Now when I try to access the NAS drive via HTTPS (I have setup SSL for web access) through Local LAN on port 9000 everything works fine. Also if I try to access my NAS drive through www.buffalonas.com/"my_nas_drive" it reseolves correctly to my public IP address of my Router and in my Router Logs I can see hits coming on to my NAS drive local IP (but not on port 9000, some other ports like 6881, 15000 etc) but cant get web access.

 

The Web access works fine on LAN but not through Internet. Can anyone help me figure out whats worng with the setup or if anything needs to be done on my NAS drive? Also one thing to note - Auto Firewall Configuration does not work in my case, so have to setup web access port on my NAS manualy to 9000.

 

Regards,

Ketan 


PCPiranha

  • Big Bull
  • *****
  • Posts: 2209
Re: Can't Web Access Linkstation Live through Internet
« Reply #1 on: March 26, 2009, 11:00:49 pm »
If you're able to access it locally but not remotely then it must be a port forwarding issue.  I have seen it not work before with DMZ so still try to forward the port on the router.  If the UPnP auto configure firewall didnt work than you must forward port 9000 to get it to work.  Also make sure you have external port 9000 typed in in the web access service setup section.

Ketan

  • Calf
  • *
  • Posts: 2
Re: Can't Web Access Linkstation Live through Internet
« Reply #2 on: March 27, 2009, 03:27:32 pm »
   

Thanks for the info, but I have already done that. The port forwarding is setup properly and when I try to web browse from Internet or LAN, it does resolves to correct IP and port (9000). The only difference is it works over LAN and not through Internet.

 

Have you seen or tired web browsing the Linkstation drive through Internet? I mean just thinking if this works or not or are there any issues with this functionality. I have the latest firmware (1.07).

 

Regards,

Ketan 


PCPiranha

  • Big Bull
  • *****
  • Posts: 2209
Re: Can't Web Access Linkstation Live through Internet
« Reply #3 on: March 28, 2009, 02:00:45 pm »
It appears that the port wasnt forwarded from the IP you posted from...  PM me with your buffalo NAS name, router's WAN side IP address, LS's ip address and the port forwarding settings in the router so I can confirm this.

Sheugel

  • Calf
  • *
  • Posts: 6
Re: Can't Web Access Linkstation Live through Internet
« Reply #4 on: March 29, 2009, 09:49:20 am »
   

Hello,

 

I would like to share because I've struggled with a similar issue. By using a different port for public and lan access to the web access feature, I've been able to connect the LinkStation from the outside. Be aware that lan access is set to port 9000 and can't be changed. So, I would suggest you use any other port (eg. 9001 (not 80)) for public access in your web access configuration (service setup option). Make sure in the portforwarding configuration of your router to use 9000 for lan port and whatever you chose for public port.

 

Sheugel


thierry2b

  • Calf
  • *
  • Posts: 1
Re: Can't Web Access Linkstation Live through Internet
« Reply #5 on: March 29, 2009, 12:16:19 pm »
   

Hi everybody,

 

I have exactly the same problem

 

Will be very happy to find there a solution

 

Thierry2b.....from France


Tikkaspecial

  • Calf
  • *
  • Posts: 9
Re: Can't Web Access Linkstation Live through Internet
« Reply #6 on: April 14, 2009, 01:14:48 pm »
   This thread helped me fix the same problem. It was driving me mad. As it states above you need to forward from 9000 to public 9001.  Then specify 9001 as the port in Web Access->Service Setup (disable UPnP). I also fixed the IP address of the Linkstation.

Waijadai

  • Calf
  • *
  • Posts: 1
Re: Can't Web Access Linkstation Live through Internet
« Reply #7 on: April 08, 2010, 09:08:57 pm »
   

I am having this same problem was how was this resolved?


PCPiranha

  • Big Bull
  • *****
  • Posts: 2209
Re: Can't Web Access Linkstation Live through Internet
« Reply #8 on: April 09, 2010, 04:24:51 am »

Guys, if you can access it locally then the unit and the web access feature are working fine on our end.  If it is not working from a remote location then it is a port forwarding issue.  I suggest ensuring that your modem does also act as a gateway and that you forwarded port 9000 to the IP of the linkstation.


av4st

  • Calf
  • *
  • Posts: 18
Re: Can't Web Access Linkstation Live through Internet
« Reply #9 on: November 27, 2011, 11:52:12 pm »

last time i have web access but this day my port was close and it hard to open again.....

 

is there a PORT rather that 9000 to used in linkstation?

 

regards,

 

 


davo

  • Really Big Bull
  • VIP
  • *
  • Posts: 5952
Re: Can't Web Access Linkstation Live through Internet
« Reply #10 on: November 28, 2011, 10:20:31 am »
You can use ANY port you want for web access, but if you don't know how to port forward correctly on your gateway it still won't work.
PM me for TFTP / Boot Images / Recovery files  LSRecovery.exe file.

Masquerade

  • Calf
  • *
  • Posts: 1
Re: Can't Web Access Linkstation Live through Internet
« Reply #11 on: February 27, 2013, 04:06:41 pm »

I have a more perplexing issue with Web Access.

 

I cannot access it from within the Local Network let alone through an external connection. I am going crazy trying to figure this out but I simply do not know what is happening. The IP has been set, the shares have been set, the settings and ports have been set, I also set up DynDNS on the router and LinkStation Live, still no result. Even the Android Apps will not connect, though they find the LinkStation.

 

I believe it may be the router itself cauing the issue, but I will take the input you guys give to get this resolved.

 

Thank You.


davo

  • Really Big Bull
  • VIP
  • *
  • Posts: 5952
Re: Can't Web Access Linkstation Live through Internet
« Reply #12 on: February 27, 2013, 04:13:16 pm »
Reset the linkstation via the web admin page and then reconfigure web acres, ensure your on the latest firmware for your unit.
PM me for TFTP / Boot Images / Recovery files  LSRecovery.exe file.

My_Fast

  • Calf
  • *
  • Posts: 1
Re: Can't Web Access Linkstation Live through Internet
« Reply #13 on: May 12, 2013, 12:42:28 pm »

I had the same issue. I could easily access locally but not over the internet. I fixed it after studying up on this networking stuff. I'm definitely new with this.

I found it was definitely like everyone says; port forwarding.

 

So my setup is my iMac/PC and Linkstation are connected to my NETGEAR ROUTER then to my VERIZON MODEM.

 

When connected to the ROUTER i could see the LINKSTATION locally but not over the internet.

When connected to the MODEM i could see the LINKSTATION over the internet but NOT locally.

 

I connected back to the ROUTER and had to forward the IP ADDRESS of the ROUTER via the MODEM.

So I logged into the MODEM, forwarded the appropriate ports/ip address and it worked!

 

So it definitely makes a difference when connected to the router or the modem. I knew this, but I didn't know how to fix it at first.