Author Topic: milkfish on wzr-300hp & google voice/simonics gateway not working  (Read 2753 times)

suaveman

  • Calf
  • *
  • Posts: 3

I am trying to get my nokia n900 to setup a sip account with simonics, a free sip gateway that links to my GV # so i can place free voip calls over wifi.

 

This worked on a d-link dir615 without any additional config options but  not my wzr300hp, or an older rosewill router i have that has ddwrt on it.

 

I tried setting up milkfish using this tutorial-

 

http://wiki.milkfish.org.sipwerk.com/index.php?n=Milkfish-dd.RouterConfiguration

 

But it doesnt connect.

 

One thing i can't get to work, is normally the router is setup as a router, not a gateway and the wan port is not used. The tutorial says you need a wan address, so i set up a static connection to my dsl gateway, 192.168.254.13 (works with other devices, static addresses to the modem that is), and when i plug the cable into the wan port, with the router setup as a gateway, none of the wireless devices have internet access. My lan ip is 192.168.254.12, and dhcp is setup on the 300hp. Devices get ips, but no connnection to the modem.

 

EDIT- Do i need a different subnet for my wan now? IE, 192.168.254.12 for the lan & 192.168.254.13 for the wan wont work?

 

Ideally, i'd like to have the wan work, so i can set up qos priority for voip & traffic shaping bittorrent traffic/all other ip traffic from a switch in another part of the house on one of the lan ports. My client settings on the n900 are all correct, the proxy is set to the 300hp's lan address, the ports right, stun is set to auto-detect, etc. I've triple checked the client settings, and tested it with the dlink AP and it works, so i know its the 300hp thats either misconfigured or incapable of doing what i'm attempting.

 

Or even just wan setup, with qos priority for the dlink AP for sip/voip, and throttling the other lan ports when calls are being made. But that requires wan to work, and sip traffic to make it through the 300hp, neither of which i can get to work.

 

Can anyone offer some advice for setting up milkfish/any way to get sip traffic to pass through, or getting the 300hp to work as a gateway with a static ip wan connection to my dsl modem?

 

Thanks-