Author Topic: ifc-pcie2u3 and Sabrent drive enclosure compatability  (Read 1599 times)


  • Calf
  • *
  • Posts: 1
ifc-pcie2u3 and Sabrent drive enclosure compatability
« on: June 15, 2011, 11:15:24 pm »

I recently installed the PCI-E USB 3.0 (ifc-pcie2u3). It installed just fine and seems to work fin with my USB 2.0 devices. However, I also purchased a Sabrent drive enclosure (EC-7F83). when I plug it in and turn it on it seems to install and remove the drive in quick succession and then do nothing (with no drive displayed in My Computer).


When I open device manager the ifc-pcie2u3 (displayed as "Renesas Electronics USB 3.0 Host Controller" and "Renesas Electronics USB 3.0 Root Hub") shows as normal but when I plug in and turn on the Sabrent, Device Manager starts repopulating over and over sometimes with the drive shown and mostly without it shown.


Tried uninstalling and reinstalling using latest Buffalo drivers and firmware updates. Also tried disabling all other USB controllers. No Joy. Same issue.


The drive enclosure works fine in the USB 2.0 ports.


Computer is an old Compaq (ASUS A8AE-LE with a single PCI-e rev 1.1 16X) with an AMD Athlon 4600+.


I would rather get this working rather than return it... Any ideas?


  • Tatanka
  • **
  • Posts: 81
Re: ifc-pcie2u3 and Sabrent drive enclosure compatability
« Reply #1 on: June 30, 2011, 03:25:53 pm »

Did you plug in the 4pin power connector to the PCI card?