Author Topic: [WZR-HP-G300NH] 2nd Wireless Radio Gone!?  (Read 2369 times)

roadie

  • Calf
  • *
  • Posts: 9
[WZR-HP-G300NH] 2nd Wireless Radio Gone!?
« on: January 10, 2013, 09:49:35 am »

Hey guys,

I've not had any luck solving an issue that has cropped up with my router running Gargoyle, and I was wondering whether any of you might be able to help? I initially described it here:

 

http://www.gargoyle-router.com/phpbb/viewtopic.php?f=3&t=3653&p=16384#p16384

 

Essentially I upgraded from Gargoyle 1.5.8 to 1.5.9. After doing so the 2nd wireless radio in the router doesn't seem to be spitting out a signal. Even after a reset to default configurations and downgrading back to 1.5.8, the 2nd wireless radio still doesn't seem to function. inSSIDer can only see a signal being put out on one channel and the Windows network status reports only a 130mbps speed instead of 300mbps like before.

 

Just to clarify, channel width is set to 40Mhz with the 2nd channel above (it's on 6)

 

Has anyone come across anything like this before? Some help would be gratefully received.

Thank you!


davo

  • Really Big Bull
  • VIP
  • *
  • Posts: 5952
Re: [WZR-HP-G300NH] 2nd Wireless Radio Gone!?
« Reply #1 on: January 10, 2013, 10:09:11 am »

3rd party firmwares are not supported. Only DDWRT and the Buffalo firmware.

PM me for TFTP / Boot Images / Recovery files  LSRecovery.exe file.

roadie

  • Calf
  • *
  • Posts: 9
Re: [WZR-HP-G300NH] 2nd Wireless Radio Gone!?
« Reply #2 on: January 10, 2013, 10:44:45 am »

I may well migrate back to DD-WRT if this might help me solve the problem!

 

Are the community builds supported or only the office Buffalo DD-WRT buils?


drmemory

  • Big Bull
  • *****
  • Posts: 1147
Re: [WZR-HP-G300NH] 2nd Wireless Radio Gone!?
« Reply #3 on: January 10, 2013, 11:20:01 am »

Only Buffalotech builds of DDWRT and the Buffalotech Easy FW are supported by moderators, although, our forum members might be able to assist with your questions.


buddee

  • Big Bull
  • *****
  • Posts: 547
Re: [WZR-HP-G300NH] 2nd Wireless Radio Gone!?
« Reply #4 on: January 10, 2013, 01:03:03 pm »

The wzr-hp-g300nh is a single radio unit, so you didn't loose the 2nd wireless radio because it was never there. And this is regardless of what firmware you use on it, its simply a single radio unit by hardware design. The issue you are having isn't a 2nd radio not working, its the wireless driver, a universal problem right now that has to do with the ath9k wireless driver. And the problem is going to effect (and is already) all firmwares that use ath9k based code, such as dd-wrt. Right now HT40 in ath9k has issues, so either use an older build or wait till the issue is resolved.


davo

  • Really Big Bull
  • VIP
  • *
  • Posts: 5952
Re: [WZR-HP-G300NH] 2nd Wireless Radio Gone!?
« Reply #5 on: January 11, 2013, 06:59:50 am »

I assumed he was talking about a virtual AP. However your probably correct.

PM me for TFTP / Boot Images / Recovery files  LSRecovery.exe file.

roadie

  • Calf
  • *
  • Posts: 9
Re: [WZR-HP-G300NH] 2nd Wireless Radio Gone!?
« Reply #6 on: January 11, 2013, 10:31:51 am »

Thanks for the detail.  What is strange is that if it is a driver issue included in the 1.5.9 firmware, then why does the issue continue after reinstalling 1.5.8?  Puzzling...


buddee

  • Big Bull
  • *****
  • Posts: 547
Re: [WZR-HP-G300NH] 2nd Wireless Radio Gone!?
« Reply #7 on: January 12, 2013, 08:54:35 am »

Same driver in 1.5.8 as 1.5.9, the code working around the driver in 1.5.8 is ok, still problems though, as you can read in the gargoyle forum, so its not totally in the clear, but 1.5.9 was supposed to 'fix' those problems, but all the while created new problems. So here we are now. :)

 

Also for the record, since gargoyle is openwrt based, you'd do good to keep track of openwrt's svn timeline to see when the issue will be fixed, with dd-wrt, you can't see what changes are being made to its ath9k driver because changes are made in a non-public tree, so you can't see it, but basically when openwrt's ath9k gets worked on, dd-wrt's ath9k driver does as well.


roadie

  • Calf
  • *
  • Posts: 9
Re: [WZR-HP-G300NH] 2nd Wireless Radio Gone!?
« Reply #8 on: January 13, 2013, 07:17:37 am »

OK thanks again.  Let's hope development is able to sort the issue.