Author Topic: << For Buffalo Tech Folks......."Network Mode" broken in DD-WRT - build 19484 >>  (Read 1344 times)

Fragster

  • Calf
  • *
  • Posts: 4

I had another thread here and a very helpful member recommended the new DD-WRT build to fix my WiFi issues.....

 

Well, it introduced another issue afterwards :-(. After the 19484 update on my WZR-HP-G300NH router, my wif'e's Asus laptop stopped connecting to the router!! It worked totally fine on the older 14998 build. I hard-wired the laptop into the router and it worked fine. Over the Wifi, the Atheros adapter just wouldn't connect. I checked the Win7 logs, etc and it seemed to think there was an issue with my router instead. I set up a hotspot off my Blackberry and the laptop Wi-Fi connected to that just fine, indicating it was an issue between the Atheros Wifi adapter on the laptop and the new DD-WRT build.

 

I tried changing the encrpption, power ratings, etc on the router and no go. Then for the heck of it, I changed the "network mode" setting from "N-Only" to "NG-Mixed" and voila!!! Didn't even reboot the laptop. It just connected fine.

 

I then proceed to update the Atheros driver to the latest (from their website) . Rebooted the laptop..went back into the router and changed the network mode back to "N Only" and still no-go. Changed the network mode to "NG Mixed" and laptop connects fine.

 

So at this point, I don't know whether Atheros will update their drivers to fix this or Buffalo to fix it to accomodate devices using Atheros Wifi adapters.

 

I found my solution but decided to post this here in case anybody else runs into similar issues with the new DD-WRT build (with Atheros based devices).

 

Thanks!