Author Topic: WHR-HP-GN does not connect to WEP AP as client  (Read 2191 times)

Sancael

  • Calf
  • *
  • Posts: 3
WHR-HP-GN does not connect to WEP AP as client
« on: December 22, 2011, 04:37:55 am »

Hi All!

 

I've just bought a new airstation WHR-HP-GN, it comes with the dd-wrt preinstalled v24SP2-EU-US (08/19/10) std (SVN revision 14998).

 

My problem is the following, I want to connect this station to a WHR-HP-54G that is connected to the internet - DHCP enabled -, and it's transmitting wireless signal with a WEP encryption mode (I know that WEP is unsecured, but I need it to connect Nintendo DS) .

 

Well, I want a simple wireless repeater (no WDS), so I set up the WHR-HP-GN as 'client' connected to the WHR-HP-54G, and add a phisical interface to cover a new area... and simply it does not work.

 

If I use WPA or WPA2 in the WHR-HP-54G, it works perfectly, so I am totally confused. I have been looking a solution for these forums but I have not found anything, sorry if this was posted before. 

 

I appreciate your comments/recommendations, thanks a lot in advanced. 


Sancael

  • Calf
  • *
  • Posts: 3
Re: WHR-HP-GN does not connect to WEP AP as client
« Reply #1 on: December 22, 2011, 12:30:15 pm »

I read from versions of Buffalo dd-wrt:

 

[Software Release Note]* V24-SP2 build 14998Specification Changes- Delete buttons whose functions are duplicated in MAC filter settings.  - Extend User Name length from 32 to 64 characters in Dynamic DNS settings.Bug Fix- Fix the problem that Client mode or Client Bridge cannot connect via WEP. 

 

And I am using that version! has anybody the same problems? do you recommend me to install version 17798 Alpha?


Sancael

  • Calf
  • *
  • Posts: 3
Re: WHR-HP-GN does not connect to WEP AP as client
« Reply #2 on: December 22, 2011, 02:55:32 pm »

Ok, I've changed to latest build  v24sp2 17798 alpha... and cannot connect to a WEP wireless network as client.

 

I do not understand how it is possible that the router cannot make such a simple task, even my very old Nokia N80 can do it!

 

I am seriously thinking in coming back to the shop to change it...


TristanN

  • Calf
  • *
  • Posts: 2
Re: WHR-HP-GN does not connect to WEP AP as client
« Reply #3 on: December 25, 2011, 07:25:21 pm »

In response to Sancael's repeat issue:

 

I succsessfuly used this configuration for jumping off of my negibors net for a while when mine was turned off, however i was using version "V24-SP2 build 14998" at the time and I have not tried this since I upgraded to version "v24SP2 SVN 17135". I am also using the WHR-HP-G300N, but I am sure it will work for your setup as well.

 

1. Make sure all settings match that of the primary router. Go into wireless settings and under >Wireless>Basic Settings>Wireless Physical Interface

 i. "Wireless Mode" select "Client Bridged

* "Wireless Network Mode" same as primary router.

* "Wireless Channel" Same as primary.

* SSID "Wireless Network Name" Same as primary router. All Characters must match exactly.

* "SSID Brodcast"? Enabled

* Check "Advanced Settings" and at the botom under "Network Configuration" select "Bridged"

Click Save.

 

2. Add a Virtual Interface

* "Wireless Mode" Select "AP"

* SSID "Wireless Network Name" You must choose a different network ID then the primary router or it most likely will not work.

* SSID Broadcast "Enable"

* AP Isolation "Disable"

* "Network Configuration" "Bridged"

Click Save

 

3. Go to Wireless>Wireless Security>Physical Interface

* "Security Mode" Must match primary router. WPA2-AES is strongly recommended although WEP is also supported. Its also not recommended to use WPA-Mixed mode because of random disconnects.

* "WPA Shared Key" Must match the key on primary router.

ii. "Virtual Interface" All fields must match those you just entered for Physical Interface.

Click Save

 

4. Go to Setup>Basic Setup

* Connection Type- Diabled

* STP- Disabled

* Router IP- Must be different from that of the primary. Example; if primary router is 192.168.11.1 then this router should be set to 192.168.11.2 or another address that isnt currently in use on your network.

* Subnet- 255.255.255.0

*Gateway- 192.168.11.1( or whatever your primary routers IP Address is)

* DHCP- Disable

* Local DNS- Primary routers IP Address.

ii. * Under Setup>Advanced Routing- Set Operating Mode to router

Apply Settings.

Note: After you apply these settings you will have to type the new IP Address 192.168.11.2 to access the router after the save process.

 

5. Under "Services" Tab Disable DNSMasq

6. Under "Security"? Tab- Disable all Security features

Apply Settings then reboot the router.

 

Thats it. Once you are done you will be able to connect to the Secondary router via the SSID and WPA key you set under VIrtual Interface.

 

For questions about any other devices with DD-WRT firmware you can go to www.dd-wrt.com and search for your device.


TristanN

  • Calf
  • *
  • Posts: 2
Re: WHR-HP-GN does not connect to WEP AP as client
« Reply #4 on: December 25, 2011, 08:25:51 pm »

Also, make sure you are connected to the secondary router via ethernet during configuration


joanlgr

  • Calf
  • *
  • Posts: 1
Re: WHR-HP-GN does not connect to WEP AP as client
« Reply #5 on: May 14, 2012, 03:58:13 am »

The password in WEP encryot "must" be hex. I dont know why, this router doesn't accept ASCII password in WEP encrypt.