Author Topic: WZR-HP-G300NH super-slow with DD-WRT  (Read 7234 times)

CaspianCanuck

  • Calf
  • *
  • Posts: 7
WZR-HP-G300NH super-slow with DD-WRT
« on: November 21, 2010, 04:05:57 pm »

Hi everybody!

 

I recently bought a WZR-HP-G300NH and am now struggling with very slow PPPOE speed when running DD-WRT.

 

Immediately after unpacking the router I flashed it with Buffalo's version of DD-WRT firmware (V24-SP2 build 14998), did the 30/30/30 reset and then configured it to work with my Bell Sympatico PPPOE service.  Right after configuring and connecting (before configuring any of the WIFI and other settings) I noticed that my internet connection became super-slow.  Speed tests showed 140-160 ms latency and around 700 Kb/s both up and down.  Surprised by the results I tried all sorts of imaginable tweaks in the settings, but the speed did not change a bit.

 

I then reverted back to Buffalo's stock firmware version 1.76, did the 30/30/30 reset again, then configured the PPPOE settings.  (The firmware is horribly user-unfriendly and the router restarts on every minute change are really annoying!)  My connection speeds got back to the normal range of 110-130 ms latency, close to 6000 Kb/s down and around 7000 Kb/s up, which is what I was getting before with my old Linksys router.

 

I then decided to try generic DD-WRT firmware (V24-SP2 build 14896), re-flashed the router and did the whole 30/30/30 thing again.  This time around my speed test detected around 1,250 Kb/s down and the same 700 Kb/s up and latency of 150 ms.

 

After spending several hours I am really ticked off that my experience with this router has turned out to be completely in the negative territory, unlike most people who have reviewed it online. :smileymad:

 

What's going on?  Has anyone experienced similar trouble with this router?  Am I doing something wrong?

 

 


mntbighker

  • Calf
  • *
  • Posts: 5
Re: WZR-HP-G300NH super-slow with DD-WRT
« Reply #1 on: December 05, 2010, 08:37:16 pm »

Mine is dropping packets and is all but useless too. I have tried the "user friendly" and DD-WRT firmware. My old Linksys WRT-54G is WAY better wired connected. So far this thing is really worthless. Both versions of firmware suffer massively from dropped packets. My DroidX refuses to connect no matter what I try. Generally this unit is pretty full of disappointments. I wonder if there is an affordable wireless-N300 AP/router I can replace my Linksys with. Because this sure does not appear to be it :-(  Interestingly, the sysinfo says my DSL modem is connected 10-baseT HALF duplex. I wonder if this is correct or part of the problem with dropped packets?

 

Edit: some Googling found the old Speedstream 5260's were factory configured half duplex.

 

Edit: The dropped packets were solved by replacing my chaep Speedstream DSL modem with an newer cheap Speedstream DSL modem. The phone connect issue was solved by changing from mixed mode to Personal WPS. So lets see how reliable this thing proves to be. I went back to the DD-WRT firmware.


mcg

  • Calf
  • *
  • Posts: 25
Re: WZR-HP-G300NH super-slow with DD-WRT
« Reply #2 on: December 06, 2010, 10:26:40 pm »

I had some weird slowness with wired connections through my G300NH with DD-WRT between machines on the gigabit wired LAN, running Windows XP on one machine and Server 2003 (Home Server) on another.  "netstat -s" was showing TCP retransmitted segments exceeding those succesfully sent.  On the XP machine I eventually tried disabling TCP task offloading (where the NIC manages TCP checksums/retransmits), and magically my gigabit wired connections ran at full speed with very few retransmitted segments.  My XP machine gigabit controller is Broadcom 57xx.  No idea if problem was with that card's TCP chimney offload or with the G300NH hardware or with DD-WRT, but something definitely was not working right.  Disabling TCP offloading on my XP machine made all the G300NH DD-WRT pages very snappy to load and transfers to/from the home server through the G300NH at 90% of gigabit rates.

 

Search for DisableTaskOffload registry setting and give it a try if you have slow wired gigabit connections with this router or see high retransmitted segments count under "netstat -s".  It made a big difference for me.

 


baconismidog

  • Calf
  • *
  • Posts: 11
Re: WZR-HP-G300NH super-slow with DD-WRT
« Reply #3 on: December 08, 2010, 08:07:29 am »

+ 1 

 

I had the 1.72 firmware for a long time.  I had been aching for DD-WRT as I've been running custom router firmware since Talisman on my WRT54GL (when you could only use the L.inux router for custom builds).  I bought this knowing that Buffalo would be coming out with a DD-WRT for it soon.

 

Even though my 1.72 was working fine, I upgraded the the DD-WRT.  OMFingG! The wireless signal turned to a caca-taco.  The hardwired devices were fast, fat and happy, but anything that tried to get on wireless with the newest DD-WRT was SOL.  They authenticated fine fine, but page loads were abysmal and packets were dropping as if Snoop was on my network.  

 

Before you ask me if I (name your favorite troubleshooting step here), I power cycled the router, pulled the pulg, reconfigured settings, reset to default, bounced all wireless devices, bounced the modem and router, re-applied DD-WRT firmware. I did many of these things several times. Still, wireless speeds like listening to your grandmother tell you about a website (you see, you go to hache.teetee.pee. Slash. Slash. Colon. dubya.dubya.dubya....)

 

Disappointed. Yeah, my disappointment goes all the way to eleven here.

 

 

Even though I figured it would brick my router I was so sad I didn' t care. I just applied 1.76 directly over the DD-WRT from the DD-WRT GUI.  Bingo. Back to the buffugliness.  Yeah, it is crazy looking, yeah, the control locations look like they were decided upon by throwing numbered wads of bubblegum at the wall and yeah, it frickin reboots after EVERY (!!!) stinking change which I don't understand. Somehow the bittorrent client is able to cache torrent downloads before writing to the disk, but the stupid firmware can't cache a few edits to checkboxes so I can edit a few pages before my 50s restart?  WTH?

 

But you know what the worlds ugliest firmware does well?  Route wirelessly.  Thanks, buffugly, tanks berry mush.


Aveyer

  • Big Bull
  • *****
  • Posts: 501
Re: WZR-HP-G300NH super-slow with DD-WRT
« Reply #4 on: December 08, 2010, 11:04:49 am »

You must be configuring something wrong, its working fine here. ZERO packet loss and no dropped connections or slow downs.

 

Try:

Mixed mode

a different wireless channel

20mhz

RTS/CTS Protection

RTS enabled

threshold 2346

TX  and RX Antenna Chains  1+2+3

Sensitivity range (ack timing)    0


CaspianCanuck

  • Calf
  • *
  • Posts: 7
Re: WZR-HP-G300NH super-slow with DD-WRT
« Reply #5 on: December 08, 2010, 01:26:31 pm »

@Aveyer:   I never got to test the WiFi speed because my Internet connection was 1/10 of its normal speed with DD-WRT installed.  How do you connect to the Internet?  PPPoE?


Aveyer

  • Big Bull
  • *****
  • Posts: 501
Re: WZR-HP-G300NH super-slow with DD-WRT
« Reply #6 on: December 08, 2010, 01:40:59 pm »

Fixed wireless, i give it a static IP.


CaspianCanuck

  • Calf
  • *
  • Posts: 7
Re: WZR-HP-G300NH super-slow with DD-WRT
« Reply #7 on: December 08, 2010, 02:42:58 pm »

@Aveyer:  And you don't experience any slowdown in the speed of your internet connection?


baconismidog

  • Calf
  • *
  • Posts: 11
Re: WZR-HP-G300NH super-slow with DD-WRT
« Reply #8 on: December 09, 2010, 09:38:32 pm »

I tried all kinds of settings. Default, different non-routable classes, the whole nine yards.  I'm pretty sure I hit all the high points during my several reverts back to default and re-flash, but as it stands I'm not revisiting DDWRT for about 12 months. I'll wait for a new firmware release or two.  Then, I'll revisit and tweak those TX/RX etc.  I used to LOVE switching up the TX/RX on my talisman and then pulling the antennas and doing speed tests.  

 

.My router is just pewp with DDWRT.  I totally believe yours works, because IMO, if you get a good buffalo you're stoked, but if you get a grumpy one your skrewed.

 

I just got one of the bent-buffalo ones. Too bad that its fully out of warranty.  I guess I should be happy that I'm one of the few that the default firmware works for. Hell, I can format XFS and you DD-WRT suckers cant! HA.

 

But seriously, don't even get me started on the USB thing.  God, you have to have a fat partition on the disk already before it will format the disk as XFS.  How does that make sense?


scajjr2

  • Calf
  • *
  • Posts: 20
Re: WZR-HP-G300NH super-slow with DD-WRT
« Reply #9 on: December 11, 2010, 07:07:52 am »

Supposedly dd-wrt is working on using the ath9k wifi driver (which openwrt uses) to replace the madwifi driver it currently uses(which is the main cause it seems of the slow wireless N speeds).

 

Sam


newaj

  • Calf
  • *
  • Posts: 6
Re: WZR-HP-G300NH super-slow with DD-WRT
« Reply #10 on: December 11, 2010, 02:23:00 pm »

That's slow because you are not using the right firmware of the router, I believe you are using a third party firmware. I am afraid you lose the warranty on it, too.



CapnSmith

  • Buffalo
  • ***
  • Posts: 153
Re: WZR-HP-G300NH super-slow with DD-WRT
« Reply #12 on: December 13, 2010, 12:49:32 pm »

I don't recall where, exaclty, but I seem to remember hearing about a possible solution to the PPPoE slowdown issue with the DD-WRT firmware.

 

Try setting the MTU to Auto, I believe it defaults to Manual, and a default size when you originally set up the router for DD-WRT.

 

Another option is if the MTU is Auto, try setting it to Manual, and contact your ISP to see what MTU size they require, and set the DD-WRT accordingly.


CaspianCanuck

  • Calf
  • *
  • Posts: 7
Re: WZR-HP-G300NH super-slow with DD-WRT
« Reply #13 on: December 19, 2010, 12:07:45 pm »

CaspianCanuck

  • Calf
  • *
  • Posts: 7
Re: WZR-HP-G300NH super-slow with DD-WRT
« Reply #14 on: December 22, 2010, 10:09:31 am »

I finally ended up restoring the stock firmware and now the router works fine. I get a stronger wifi signal throughout the house than I did before with my old Linksys, and the PPPoE speed is back to normal.