Author Topic: 2gb ext3 formatted usb thumb drive won't mount via GUI on new WZR-HP-G300NH  (Read 1366 times)

unyalli

  • Calf
  • *
  • Posts: 5

Yes of course I've searched and read wiki's.

 

Brand new WZR-HP-G300NH.

Firmware: DD-WRT v24SP2-EU-US (08/19/10) std

 

2gig usb thumb drive formatted ext3. Enable everything in usb tab except 1.1 and select /jffs as mount point. Apply AND save then reboot and no drive. In ssh I see /dev/disks/disk0/disk and /dev/disks/disk0/part1. I can mount the drive with mount -t ext3 -o noatime /dev/disks/disk0/part1 /jffs and create directories etc... Why won't this thing mount a simple usb flash drive?


Jotin

  • Big Bull
  • *****
  • Posts: 4201

Did you buy this in the UK? 


unyalli

  • Calf
  • *
  • Posts: 5

Bought from Amazon, I believe in the US. I'm in Wyoming.

 

So the UK models have this problem? I've not seen this in the forums here or dd-wrt.


Jotin

  • Big Bull
  • *****
  • Posts: 4201

No, I just thought that it might not be an American model because last I checked the DDWRT firmware didn't have the Nas functionality. I'll have to double check this then. Could you post a screen shot of the Nas functionality in your DDWRT firmware? 


unyalli

  • Calf
  • *
  • Posts: 5

NAS is disabled. I'm in the USB tab.

 

Can't see how to upload an image. I see where you can link to on on the net but I don't have a simple way of putting images on the net (yet, I get this working and I will.)

 

As per my original post everything in the USB tab is enabled except the two 1.1 options.

 

What does the unit need to see for mounting usb flash (or hard) drive? Here is what my unit can see.

 

root@UNGateway:~# ls -l /dev/discs/disc0/
brw-------    1 root     root       8,   0 Jan  1  1970 disc
brw-------    1 root     root       8,   1 Jan  1  1970 part1

 


Jotin

  • Big Bull
  • *****
  • Posts: 4201

You click on the picture icon and then select "browse" next to select file and you can browse your pc for the screen shot. 


unyalli

  • Calf
  • *
  • Posts: 5

When I click the picture icon I can provide an image url. There is no browse button.


unyalli

  • Calf
  • *
  • Posts: 5

Solved it. You do not support ext3. Reformatted to ext2 and it automounted.