Author Topic: Linkstation Pro LS-XH2.0L painfully slow transfer speeds  (Read 1393 times)

doctorhifi

  • Calf
  • *
  • Posts: 4
Linkstation Pro LS-XH2.0L painfully slow transfer speeds
« on: August 06, 2011, 09:07:42 am »

I have:

Linkstation Pro LS-XH2.0L

Firmware version 1.52

I'm using: 408.2 GB  of the 1848.4 GB available (22.1%)

I am using Jumbo Frame Size of 9694, although this made no difference in speed.
I am not using FTP or AFP.
Ethernet DHCP is Disabled
 
My PC is running Vista

My router is a Dlink DIR-655, which is Gigabit & wireless N. 

Note: the Linkstation is WIRED to the network as is the PC I am tranferring from/to so there is NO wireless involved.

All wiring is CAT5

 

When I copy files TO the linkstation from my PC over the network, I have speeds between 500-640 kb.

When I copy files FROM the linkstation to my PC over the network, I have speeds between 1-1.5 mb

 

I suspect there are settings that are wrong somewhere, but I am at a loss.

 

An thoughts on what I can try in order to improve this?  ?

2 hours to tranfer a 2.5 GB files is really unacceptable.

 

?

 


davo

  • Really Big Bull
  • VIP
  • *
  • Posts: 5955
Re: Linkstation Pro LS-XH2.0L painfully slow transfer speeds
« Reply #1 on: August 06, 2011, 09:51:54 am »

and if you iliminate the router out of the equation and test the tranfer on a direct connection?

PM me for TFTP / Boot Images / Recovery files  LSRecovery.exe file.

doctorhifi

  • Calf
  • *
  • Posts: 4
Re: Linkstation Pro LS-XH2.0L painfully slow transfer speeds
« Reply #2 on: August 06, 2011, 01:36:59 pm »

If I connect the Linkstation directly to my PC- ethernet port on PC to ethernet port on Linkstation- I am unable to find the Linkstation using NASNavigator2 or browse to the location on my PC.

 

 

 

 


doctorhifi

  • Calf
  • *
  • Posts: 4
Re: Linkstation Pro LS-XH2.0L painfully slow transfer speeds
« Reply #3 on: August 14, 2011, 10:34:04 am »

Any help?

I have another PC on my network running Windows 7 and I can transfer FROM the Linkstation to this PC at rates of ~ 7-8MB.  But transferring TO the linkstation from either this PC or my main one running Vista results in speeds of <300KB.  This is really frustrating.  Why good speeds one direction and not the other?

Can anyone point me to some info on things I can check.


doctorhifi

  • Calf
  • *
  • Posts: 4
Re: Linkstation Pro LS-XH2.0L painfully slow transfer speeds
« Reply #4 on: August 14, 2011, 11:46:33 am »

Well I guess I fixed the problem.

Went into my network card settings:

Control Panel > Network Connections > right click on Local Area Connection, select Properties

(mine is a Nvidia nForce 10/100 Mbps Ethernet adapter)

The select the Advanced tab and in the Property box click on Speed & duplex settings and then selected 100 Mbps Half Duplex from the Value window.  If I had it set to Full duplex, my speeds tanked.

 

Also, some other suggestions that DID NOT make a difference:

1.  Turning off Remote Differential Compression.  On or Off made no difference for me so I left it ON.

2.  Disabling Flow Control on the network adapter.  I left it on Rx & Tx enabled.