Author Topic: Can't access my 1TB Buffalo external HD  (Read 15657 times)

davo

  • Really Big Bull
  • VIP
  • *
  • Posts: 5952
Re: Can't access my 1TB Buffalo external HD
« Reply #15 on: June 12, 2013, 10:36:23 am »

I very much doubt it is the physical HDD at fault. More than likely it is the USB-SATA bridge. If warranty is not a problem then remove the HDD and connect it to a spare SATA port on a PC.

PM me for TFTP / Boot Images / Recovery files  LSRecovery.exe file.

Mayday

  • Calf
  • *
  • Posts: 10
Re: Can't access my 1TB Buffalo external HD
« Reply #16 on: June 12, 2013, 10:40:15 am »

 am still under warranty, but i don't care about it. I will buy a spare SATA port and let you know.


Mayday

  • Calf
  • *
  • Posts: 10
Re: Can't access my 1TB Buffalo external HD
« Reply #17 on: June 13, 2013, 06:35:34 am »

I've bought a new case today with an integrated Sata, but still the same problem!! I have tried this new case in 2 different PC and always the same noise then nothing... What do you think? Is it physically damaged, and do you think that the recovery data can help? 

 

Thanks for your time!


ratty2013

  • Buffalo
  • ***
  • Posts: 117
Re: Can't access my 1TB Buffalo external HD
« Reply #18 on: June 13, 2013, 09:13:21 am »

Mayday wrote:

I've bought a new case today with an integrated Sata, but still the same problem!! I have tried this new case in 2 different PC and always the same noise then nothing... What do you think? Is it physically damaged, and do you think that the recovery data can help? 

 

Thanks for your time!


I've already said that it is physically damaged and beyond any use. If the data is of absolute importance then there are data recovery companies that you can send the hard drive to, but as I've already said they are very expensive (costing upto thousands).


Mayday

  • Calf
  • *
  • Posts: 10
Re: Can't access my 1TB Buffalo external HD
« Reply #19 on: June 14, 2013, 02:31:52 am »

Just came back from a recovery company, so it's completly broken after 3 months of use in the same conditions than another external (3 years old)... so no Buffalo anymore!

 

Thanks guys for your time and your help!