Author Topic: Thumbnail photo issue NAS?  (Read 4856 times)

taxi657

  • Calf
  • *
  • Posts: 3
Thumbnail photo issue NAS?
« on: December 03, 2012, 10:01:44 am »

Hi,

 

Here goes, would be greatly appreciative to anyone who can help with this. I will try to include everything I think is relevant to the issue.

 

Hardware

NAS  - Buffalo Linkstation pro duo 4 TB

TV  - Samsung UE40D5520

Camera – Canon EOS 1100d

 

 

I download my camera to my NAS wirelessly which is wired to my TV and have enjoyed looking at the photo’s on the big screen. However, about 6 months ago (no software updates on any of the devices that I’m aware of) any photo’s I download (always done it the same way) have been coming up on the TV in a tiny thumbnails which is barely visible. Here is what I know

 

I can see the photo’s fine from my NAS on my computer

I can see the photo’s fine when I attach the camera directly to the TV

Another camera I have is also fine when I download to the TV.

 

Confused, anyone have any ideas? From the above I can’t figure out which one is to blame.

 

Cheers

Chris


davo

  • Really Big Bull
  • VIP
  • *
  • Posts: 5958
Re: Thumbnail photo issue NAS?
« Reply #1 on: December 03, 2012, 10:05:08 am »

Yes, this is an issue with the media server, if the photos are larger than 4MB then they are displayed as a thumbnail size.

PM me for TFTP / Boot Images / Recovery files  LSRecovery.exe file.

taxi657

  • Calf
  • *
  • Posts: 3
Re: Thumbnail photo issue NAS?
« Reply #2 on: December 13, 2012, 10:12:32 am »

Hi thanks for your response, can I change this somehow?


CTB_WD

  • Calf
  • *
  • Posts: 5
Re: Thumbnail photo issue NAS?
« Reply #3 on: January 17, 2013, 02:56:24 am »

Hi

 

I have exactly the same problem displaying full size photos off my Buffalo Linkstation Duo NAS server.

 

Updated Linkstation LS-WXLB9E to firmware 1.6,  the latest

Updated Linkstation DNLA Server to latest

WD TV Live. Firmware 1.12.14 the latest

    Video ok

    Music ok

    Photos come up on the WD TV Live as thumbnails. NOT their full size

 

I have other DNLA clients that all display photos off the server correctly...........

IPad displays photos correctly

IPhone ok

Nokia E 72 OK

 

CAN I INSTALL AN UPDATED TWONKY SERVER ON THE LINKSTATION lAS THIS APPEARS TO BE THE PROBLEM?

 

Any help would be appreciated.


CTB_WD

  • Calf
  • *
  • Posts: 5
Re: Thumbnail photo issue NAS?
« Reply #4 on: January 19, 2013, 10:48:54 am »

Hi

 

I have found some interesting info on the Twonky forum, as per the post below, which appears to offer a solution to the problem

 

HOW DO I FIND AND EDIT clients.db ON MY LINKSTATION DUO WITHOUT HAVING TO ROOT?

 

 

 
Kiran (Official Rep) 10 months ago
If your photos aren’t shown in correct resolution through Twonky then you can try the below mentioned change. 

1. Navigate on your PC or NAS to locate the clients.db file. In Windows PC you can find it here: C:\Program Files\TwonkyMedia\resources\clients.db 

2. Before editing the original file make a copy of that clients.db file and store it outside of the TwonkyMedia folder. 
3. Open the clients.db file using notepad or text editor. ( You might have to rename clients.db file to clients.txt file ). 
4. Search for “WD ”. (If you are using any other device/player then look for the device entry according to the profile selected as Media receiver type for that device.) 
5. Edit the line that begins with “TR:” so that “JPEG 160x160” is changed to “JPEG_HD”. 

NA:WD TV HD Live Media Player 
DD:WD TV HD Live 
XM:DLNA15 
XM:TV4IDS 
DB:FIX 
XM:NOEMBEDDEDALBUMART 
TR:JPEG160x160,JPEG1920x1080 

Modify this line as:- 
TR:JPEG_HD, JPEG1920x1080 
DF:devicedescription-wd-live.xml 

This is an example for WD TV live, similarly we can edit the client.db file for other media receiver types.

 

 


CTB_WD

  • Calf
  • *
  • Posts: 5
Re: Thumbnail photo issue NAS?
« Reply #5 on: January 22, 2013, 02:31:44 pm »

I have solved my problem and all is working perfectly Without having to root or edit client.db.

 

Communicated with the Twonky Server on my Linkstation

by http://192.168.0.2:9050. ( you need your Linkstations IP address

went to Advanced Settings.   .......  

Media Receivers

forced the device selected for my WD Live TV  ( identified by its MAC and IP Adress) in the table to WD LIVE TV from the drop down list.

Saved the new table 

Restarted NAS

 

All working I.e.  all pictures shown at their full  resolution.