Author Topic: strict allocate = yes  (Read 7522 times)

cjm51213

  • Calf
  • *
  • Posts: 17
strict allocate = yes
« on: September 04, 2012, 10:10:09 pm »

Hi Folks,

 

WBAdmin, the Windows Server 2008r2 backup utility fails when I am backing up something less then a complete disk to the Linkstation and the explaination has something to do with sparse files.  There are discussions in several places, but the relvant explanation is:

 

  Failure: The file level backup to the NAS device running samba failed with "The version does not support this version of the file format"
  When:    The failure happens while the .VHD file created by Windows Backup is mounted during backup.
  Reason: The .VHD file is created as a sparse file and this is not supported by the native VHD driver and hence mounting of the .vhd failed.
  Solution:Adding "strict allocate = yes" to the smb.conf and restarting the samba.

 

I assume the link station is running some version of SaMBa.  So, how can I add "strict allocate = yes" to the Link Station?  

 

Thanks for the help,

 

Chris.

 

 

More information:

http://blogs.technet.com/b/asiasupp/archive/2010/11/03/windows-server-backup-failed-with-error-quot-the-version-does-not-support-this-version-of-the-file-format-quot.aspx

-- and --

http://social.technet.microsoft.com/Forums/en-US/windowsbackup/thread/13bb79e9-c970-4805-88cb-2000b3348070

 

 

 


cjm51213

  • Calf
  • *
  • Posts: 17
Re: strict allocate = yes
« Reply #1 on: September 07, 2012, 11:02:25 am »

Hi Folks,

 

smb.conf is protected against changes, so without the root password on the unit, I can't fix this myself.  The "firmware" is password protected, so with out this password, I can't fix this myself.

 

How am I supposed to modify the SaMBa settings on this unit?

 

Thanks for the help,

 

Chris.


davo

  • Really Big Bull
  • VIP
  • *
  • Posts: 5943
Re: strict allocate = yes
« Reply #2 on: September 07, 2012, 11:04:14 am »

cjm51213 wrote:

How am I supposed to modify the SaMBa settings on this unit?

 

Thanks for the help,

 

Chris.

 

You're not ment to alter the settings.

PM me for TFTP / Boot Images / Recovery files  LSRecovery.exe file.

cjm51213

  • Calf
  • *
  • Posts: 17
Re: strict allocate = yes
« Reply #3 on: September 07, 2012, 11:07:01 am »

Hi Davo,

 

I didn't think I was supposed to change them, but in this case, they need to be changed.  How do I get this fixed?

 

Thanks for the help,

 

Chris.


davo

  • Really Big Bull
  • VIP
  • *
  • Posts: 5943
Re: strict allocate = yes
« Reply #4 on: September 07, 2012, 11:34:09 am »

http://buffalo.nas-central.org/wiki/Category:LS-WXL

 

Bare in mind this will void your warranty.

PM me for TFTP / Boot Images / Recovery files  LSRecovery.exe file.

cjm51213

  • Calf
  • *
  • Posts: 17
Re: strict allocate = yes
« Reply #5 on: September 07, 2012, 12:51:05 pm »

Hi Davo,

 

You are my hero!

 

Yes.  This would void my warranty, and it turns out that the warranty is less important than you might initially suspect.  Unless I can get the LinkStation to work with WBAdmin, it has little value to me. So, I'm willing to risk total loss of the unit on the gamble that I can get it to work in the capacity that I need.