Recent Posts

Pages: 1 ... 6 7 [8] 9 10
71
Storage / Re: LS220D Fan / Debian question
« Last post by GMAN73 on July 12, 2019, 08:10:47 am »
Thanks for that info I will give that a go.

Cheers

G
72
Storage / Re: LS220D Fan / Debian question
« Last post by 1000001101000 on July 12, 2019, 06:34:05 am »
SSH/SFTP/HTTPS donít work well within the stock firmware because the tools are old and donít support the current cyphers/protocols. That is why I provided that example that only uses telnet/HTTP.

Try using the commands from my post, that should get you up and running.
73
Storage / Re: LS220D Fan / Debian q
« Last post by GMAN73 on July 12, 2019, 02:43:47 am »
Think that I might buy another NAS I donít know whatís going on I can connect to the LS220D do the prompt cd /boot but when I do sftp gerry@192.168.0.11 I get the message connection closed by 192.168.0.11 Couldnít read packet: Connection reset by peer

So looks like thatís stopping me from copying files to the boot folder
74
Storage / Re: LS441DE connection loss
« Last post by 1000001101000 on July 11, 2019, 11:18:20 pm »
someone may have some better ideas, but my first suspicion would be the device overheating and crashing. Possibly also corruption of the firmware causing intermittent failures.

I'd probably make sure the fan appears to be working clean out any dust inside the device. Then if there's still trouble pull the drives and run diagnostics on a PC. Possibly try re-installing the firmware if the drives are healthy and you still have trouble.

If your interested you could also install Debian on the device rather than the stock firmware. This would among other things make it easier to monitor system/drive temperature using lm-sensors and hddtemp. You can find details about that process at:
https://github.com/1000001101000/Debian_on_Buffalo
75
Storage / Re: PASSWORD RESET FOR TS-QVH
« Last post by 1000001101000 on July 11, 2019, 11:12:08 pm »
Out of interested I tried resetting mine and was able to do so without too much trouble.

The process was as follows:

1. Download an older Linux LiveCD image such as the Ubuntu Desktop 14.04.6 LTS install CD. (I initially tried my Debian 10 installer but I think the modern kernel conflicted with the older kernel used by the buffalo firmware.)
2. Write the CD image to a usb drive
dd if=ubuntu-14.04.6-desktop-amd64.iso of=/dev/sdx bs=512
3. Shut down the Terastation, attach a monitor and keyboard/mouse
4. Flip the boot switch on the terastation to "USB" and insert the usb drive
5. Power on the terastation and wait until it boots into ubuntu
6. open a terminal window, switch user to root
sudo su
7. install mdadm
apt-get update; apt-get install mdadm
(ignore any errors related to postfix)
8. assemble all software raid arrays using mdadm
mdadm --assemble --scan
9. determine which array is associated with the second partition of each disk (sda2 etc), mide was /dev/md125
lsblk or mdadm -E /dev/sda2
10. mount that array to /mnt
mount /dev/md125 /mnt
11. chroot into /mnt and load a shell
chroot /mnt /bin/bash
12. change the admin password from within the chroot environment
passwd admin
13. exit the chroot environment
exit
14. unmount the array
umount /mnt
15. flip the switch on the back to "hdd" and reboot the device
16. When the terastation comes back up use the password you set to log into the web interface.
17. Change your password again using the web interface to ensure it gets set properly for all firmware features.
18. remove the usb drive if you haven't already, reboot the device again for good measure.
76
Storage / LS441DE connection loss
« Last post by dbdny on July 11, 2019, 06:29:02 pm »
I have an LS441DE that I use for Video storage. For some reason the unit stops working properly. It is powered on, connected to a UPS and there is connectivity(I can ping it fine) but the cameras stop talking to it and I can not access it through any browser or the NAS navigator. Once I reboot it, its fine for a few days. It is set for DHCP so the DNS is fine and I do not have a sleep timer set. I don't know what else to look for. It has been doing this for as long as I have had it but I didn't care until someone set fire to a planter in the front yard. Any help would be great.

Thank you
 
77
Storage / Re: LS220D Fan / Debian question
« Last post by GMAN73 on July 10, 2019, 07:04:22 pm »
thanks for the post, I'll give it another try tomorrow.  Ive reset the SSH and Ive now getting a warning about hosts someone could be doing something nasty, offending ECDSA key in home/.ssh/known-hosts:1 host key verification failed connection reset by peer

I'll try tomorrow thanks for the posts.

G
78
Storage / Re: LS220D Fan / Debian question
« Last post by 1000001101000 on July 10, 2019, 06:59:28 pm »
I just ran through it on my ls220de without using sftp, instead I used wget and the python simple http server. here are the commands I used:


$ java -jar acp_commander_cli.jar -t 192.168.1.131 -ip 192.168.1.131 -pw password -c "/bin/busybox telnetd&"
$ java -jar acp_commander_cli.jar -t 192.168.1.131 -ip 192.168.1.131 -pw password -c "chmod -R 777 /boot"
$ cd ..
$ cd Buster/installer_images/
$ python -m SimpleHTTPServer 8000 >/dev/null 2>&1 &
[1] 31817
$ telnet 192.168.1.131
Trying 192.168.1.131...
Connected to ls220de.
Escape character is '^]'.

BUFFALO INC. LinkStation series
LS220DED26 login: admin
Password:
[admin@LS220DED26 ~]$ cd /boot
[admin@LS220DED26 boot]$ mv uImage.buffalo uImage.buffalo.bak
[admin@LS220DED26 boot]$ mv initrd.buffalo initrd.buffalo.bak
[admin@LS220DED26 boot]$ wget http://192.168.1.146:8000/initrd.buffalo
--2019-07-11 08:51:02--  http://192.168.1.146:8000/initrd.buffalo
Connecting to 192.168.1.146:8000... connected.
HTTP request sent, awaiting response... 200 OK
Length: 31138868 (30M) [application/octet-stream]
Saving to: `initrd.buffalo'

100%[=============================================================================================================>] 31,138,868  20.4M/s   in 1.5s   

2019-07-11 08:51:03 (20.4 MB/s) - `initrd.buffalo' saved [31138868/31138868]

[admin@LS220DED26 boot]$ wget http://192.168.1.146:8000/uImage.buffalo.ls220d
--2019-07-11 08:51:37--  http://192.168.1.146:8000/uImage.buffalo.ls220d
Connecting to 192.168.1.146:8000... connected.
HTTP request sent, awaiting response... 200 OK
Length: 4251893 (4.1M) [application/octet-stream]
Saving to: `uImage.buffalo.ls220d'

100%[=============================================================================================================>] 4,251,893   --.-K/s   in 0.1s   

2019-07-11 08:51:37 (28.0 MB/s) - `uImage.buffalo.ls220d' saved [4251893/4251893]

[admin@LS220DED26 boot]$ mv uImage.buffalo.ls220d uImage.buffalo       
[admin@LS220DED26 boot]$ sync
[admin@LS220DED26 boot]$ exit
logout
Connection closed by foreign host.
$ java -jar acp_commander_cli.jar -t 192.168.1.131 -ip 192.168.1.131 -pw password -c "reboot"
$ ssh installer@192.168.1.131
The authenticity of host '192.168.1.131 (192.168.1.131)' can't be established.
RSA key fingerprint is SHA256:f58ol5GJgIp+D8cPGkgqW8ZVpoq0cgnKOyHpfbMOE+M.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added '192.168.1.131' (RSA) to the list of known hosts.
installer@192.168.1.131's password:
79
Storage / Re: LS220D Fan / Debian question
« Last post by GMAN73 on July 10, 2019, 05:08:39 pm »
Think Iím gonna call it a day with this.

After I go to cd / boot

 I enter

sftp Gerry@192.168.0.11 (my computer IP from NIC)
Comes up about ECDSA key finger print
Are you sure you want to connect - I select  Yes
Cones up Gerry@192.168.0.11 password
I enter 1973 thatís the password I use to logon
Cones up permissions denied.

Shame as I really wanted to try this firmware

G

80
Storage / Re: LS220D Fan / Debian question
« Last post by 1000001101000 on July 10, 2019, 04:11:35 pm »
I usually use sftp at that point. The commands will be similar to:

[admin@LS220DEABF boot]: sftp <your user>@<your PC's IP>
> cd ď/home/gerry/gmanĒ
> get *.buffalo
Pages: 1 ... 6 7 [8] 9 10