Buffalo Forums

Products => Storage => : Louis July 29, 2009, 07:26:12 PM

: HD-CELU2 clock
: Louis July 29, 2009, 07:26:12 PM

HD-CE640LU2 with BUF-CELU2-1.4.7 Loader 3.5 W1.9 firmware used in NAS mode.  Actually the second unit.  Both have had clock problems.  No matter what Date and Time and/or NTP server settings are saved, the clock loses time - typically 3-5 minutes every hour.  After a few hours this seems to make a significant impact on the network being able to find and communicate with the unit.  Tech support is aware of the problem but has no fixes.  Any suggestions?

: Re: HD-CELU2 clock
: disputator July 30, 2009, 06:26:04 AM
   I don't have this device but one time when I had the problem on a Buffalo NAS the internal clock didn't work well but NTP was ok. When I had problems I did a ping test to the NTP and relized the server was not always available. That is what I would do first. Make sure you use a reliable NTP and it is not blocked.
: Re: HD-CELU2 clock
: Louis July 30, 2009, 07:58:55 AM
   I already checked that.  It is the same time server I use for XP on the computers.  Also, the Buffalo NAS unit only updates once a day - which it does - but at 5 minutes an hour it is only close once a day!  Thanks for the idea.
: Re: HD-CELU2 clock
: Louis August 03, 2009, 08:21:32 PM

The second unit has now been in service long enough to say unequivocally that it is worse than the first unit.  This one loses about 15 minutes an hour.  Tech support can only offer to send yet another unit.  "Maybe one of them will work."  It is amusing when last night's backup files are date/time stamped yesterday afternoon.



: Re: HD-CELU2 clock
: disputator August 04, 2009, 02:47:26 AM

Hmm, in this case I would use USB for the backup. So fars I understood this unit is a hybrid. (I tried it once) Of course it has to be placed near the backup machine but the unit can be(stay) physically connected to USB and network and you switch with the little function switch on the front of the unit between USB and network.




: Re: HD-CELU2 clock
: Louis August 04, 2009, 11:12:12 AM
   The unit might work that way, I have not tried it in the USB mode.  If I had wanted a USB hard drive I would not have purchased this unit.  This unit is located in a fireproof room in the basement of the building.  In fact, each computer has a separate Buffalo USB hard drive sitting next to it for nightly backups.  This one is supposed to back up critical files on a weekly basis.  I really do not want to carry it around every week.  Its size, power consumption, and other specs made it ideal for the application.  The bad clock makes it hard to track the backups.  I never expected that Buffalo could not make a clock work.
: Re: HD-CELU2 clock
: sinnr March 08, 2010, 02:38:15 PM


i realize this is an older thread, but I have three of these drives (two 1TB and one 640GB) all of which have clock issues.  I'm curious if this is a widespread problem, as I didn't see any other threads except this one.  All are running the 1.4.7 software as outlined in the original post.


I don't think that replacing the drive and "hoping for the best" is a solution.  Going to USB isn't a solution either, as these are intended to have shared data and be available for backups from multiple PCs.


: Re: HD-CELU2 clock
: Louis March 08, 2010, 09:30:22 PM

I still have the second unit and it still has clock problems.  At least it is nice to know that I do not have the only one with a problem.  I have looked several times but 1.4.7 is still the current software.  Thanks for the reply.

: Re: HD-CELU2 clock
: sinnr March 09, 2010, 10:56:40 AM

I looked more closely and it turns out that I have one unit which seems to have a functional clock, and it's running 1.4.B firmware.  I've contacted tech support, but so far their response has been that I need to go into the administrator to set the clock, which of course has nothing to do with the actual problem.


I also have problems with NTP on all 3 drives, so I need to set the time manually to get even close. 


If I learn anything I'll post it here.  I just got the drives over the weekend, and haven't had too much time to play, but it's not as if there are a plethora of options to work with when trying to troubleshoot the issue.


: Re: HD-CELU2 clock
: sinnr March 15, 2010, 01:46:06 PM

I was never able to locate 1.4.B firmware so I could try it on my other drives, but I did find a 1.4.C from Buffalo in Asia (Hornington Computer).  I have not given it a try, but I did find the following interesting tidbit in the readme for the firmware:


Ver.1.4.7 >> Ver.1.4.A
Ver.1.4.A is displayed as "BUF-CELU2-1.4.A LOADER 3.5W1.9"in the web settings page.

Extra function added


This seems to support that going away from the 1.4.7 firmware will help the clock behavior.   I have no idea why updated firmware is not avaiable via Buffalo directly.


The firmware can be found at http://support.hornington.com/kb/question.php?ID=460

: Re: HD-CELU2 clock
: sinnr March 15, 2010, 09:29:07 PM

Went to the 1.4.C and the drives automatically picked up the correct time with no adjustments needed.  I'll see how long it lasts, but at this point 1.4.C appears to be a legitimate fix for the clock.


I'll also watch for other issues, since I'm only using them for redundant data anyway, if there is a problem it should be pretty easy to notice.

: Re: HD-CELU2 clock
: Louis March 15, 2010, 10:08:43 PM

I thought I responded but I don't see it on the board.  I downloaded the 1.4 C and will try it next week when I am back at home.  This would be great if it solved the clock problem.  I will let you know.  Thanks for posting your efforts.

: Re: HD-CELU2 clock
: sinnr March 17, 2010, 10:00:10 PM

It appears to have fixed the issue for me, as all my drives are tracking closely to my system clock.  Outside of the change for daylight savings, I don't think I'll need to be doing manual adustments, but I'll continue to monitor it. 


I hope it works for you, although I'm absolutely perplexed as to why Buffalo does't offer the latest firmware and why they seem to have no knowledge of the issue. 

: Re: HD-CELU2 clock
: Louis March 28, 2010, 10:26:06 AM

Version 1.4 C solved the clock problem on my unit.  It also seems to be a little "snappier" but that could just be because of the right time.  ECO seems to work now, and it use to lock up the system most of the time.  Sinnr, you have my sincere thanks for finding this solution and sharing the information.  A few weeks ago I would have hesitated to upgrade the firmware to a "non official" version, but at this point I had nothing much to lose - I was going to junk the unit as soon as I could find another NAS that met the power and space requirements.  Again, thanks!!