Buffalo Forums

Products => Storage => : Broady June 07, 2017, 03:37:53 AM

: TS-XL/R5 F/W Updating 125 in display
: Broady June 07, 2017, 03:37:53 AM
I have just attempted to update my TS-XL/R5 to 1.66. Everything was looking good, the process appeared to be progressing correctly until the amber light came on the display read, "F/W Udating 125 (or could be I25)", appeared in the display. I know that updates can take a long time on occasions, so I left it running for 24 hours. Still the same. I forced power off and back on, still the same. I now cannot communicate with the box by either the TSUpdater or NAS Navigator 2.
Any ideas where I go next will be greatly appreciated?
: Re: TS-XL/R5 F/W Updating 125 in display
: MiG174 June 07, 2017, 01:39:19 PM
I25 - firmware updating. Do you set your region's firmware?
I had such a hang when I installed JP firmware on EU version NAS.
Connect Serial Console and see upgrade process.


: Re: TS-XL/R5 F/W Updating 125 in display
: Broady June 08, 2017, 10:18:25 AM
Thanks for the info Tatanka. I ended with Buffalo Tech support on the phone. Great people, great help. It turned out that the disks I was using had a partition on them and this needed to be deleted.
Then I need their recovery software. All sorted and working fine.
: Re: TS-XL/R5 F/W Updating 125 in display
: Eastmarch June 08, 2017, 02:49:03 PM
This makes my day.
: Re: TS-XL/R5 F/W Updating 125 in display
: fdewarren March 16, 2019, 08:57:48 AM
I hope I can re-activate this old thread...
I have the same issue on an old TS-XL/R5 with 4 drives.
It did not run for a few weeks and a recent switch on triggered 2 drives out of 4 to be marked as failed.
Needless to say I have tried a few things already, I replaced all the drives now and I would just like a clean re-start.
Nothing seems to have worked.
I am now to the situation when the TS is stuck in "F/W updating I25"
I cannot connect to it with TS updater or NasNavigator.
Any idea out to get out of this?
: Re: TS-XL/R5 F/W Updating 125 in display
: 1000001101000 March 16, 2019, 03:59:28 PM
You should be able to install the firmware without too much trouble. If possible make sure the drives are completely blank (don't have partitions) before starting.

Many of the Terastation models will boot directly into EM mode from the onboard flash memory if the drives are blank, if so it should show up in tsupdater after about 10 minutes from powering on. If so you can start at step 3:

1. Extract the required boot files from the firmware installer for your device:

2. Get the device to boot from those files using one of these methods:

3. Enable debug mode in LSupdater:

4. Finally run lsupdater to re-install the firmware on the device
(if starting from blank drives use the re-partition and re-format settings).
: Re: TS-XL/R5 F/W Updating 125 in display
: fdewarren March 16, 2019, 11:36:23 PM
Ok thanks for the new leads
I will try over the coming days.
I will let you know if it worked!
: Re: TS-XL/R5 F/W Updating 125 in display
: fdewarren March 17, 2019, 04:17:19 AM
How long are we supposed to wait after the reboot for the message "F/W updating I25" to go away?
How do I know it is not stuck again?

There seems to be no activity on the drives (no light, no sound) and the TSupdater is telling me it has waited 1200 seconds...
: Re: TS-XL/R5 F/W Updating 125 in display
: 1000001101000 March 17, 2019, 08:00:30 AM
i'm not sure of the exact time but If it's stuck at any one step over 30 minutes I think ot's safe to assume it didn't work.

how many drives are you using?
what size(s) are they?
which debug options did you enable in tsupdater?

you shoukd be able to connect to the device and see what the error is from the syslog but we may be able to figure it out without going to that much trouble depending on your answers to the above.
: Re: TS-XL/R5 F/W Updating 125 in display
: fdewarren March 19, 2019, 11:34:50 AM
All right, I have managed to be back online
I had to recheck all the disks using an old DOS program DISKPART
Then I re-installed an older version of the firmware (1.06) that I had saved from years ago... I'm not sure I sure load 1.72 since everything is working.
Everything is stable. I have re-created an array with 3x3To drives and the 4th one is set to spare. Like before.

I was not sure if the 3To were supported but the product description did say it was ok.

Thank you for your post, it lead me to the solution. I was ready to get rid of the whole thing.
The problem being that when the TS is stuck on "firmware updating" you cannot connect to the web admin or NasNavigator. So you have the turn it off the hard way, modify the drives, restart to trigger the E/M mode and then you can try something else.
But after each try, you need to verify if the disks were not modified already with partitions.
If so, you need to delete all of it again.
Lucky me I got this USB/SATA converter so I can quickly check all the drives with fdisk

Then I had this one drive which would not allow me to merge 2 partitions... That's when I got to use diskpart. But like it was not enough, it would not allow me to create a single volume afterwards!  >:(
Anyway, Now I got this. I hope I don't have to get through this &!@# again.
For the record, I am using a TS-XL/R5 bought in ... 2008 with 4 drives.