Buffalo Forums

Products => Storage => : fenrirGrey January 07, 2014, 10:03:41 AM

: Cannot delete files created using Backup Utility
: fenrirGrey January 07, 2014, 10:03:41 AM
I created a job to copy all the files from the USB disk to the NAS drive. After a few hours the backup job process failed. Now I cannot figure out how to delete the failed folder. It is using up 200 GB space.

I've tried to delete via SSH, Windows, Mac, even tried third party tools but none of them have worked. I cannot even see what is inside the folders as it gives me access denied. I'm using the admin login.

Please help!
: Re: Cannot delete files created using Backup Utility
: MWPollard May 01, 2014, 02:23:38 PM
I also have this issue. I have been on hold with a Buffalo tech for the past 15 minutes, where he is trying to find a solution that does not involve deleting the only shared folder on the 24TB TeraStation.

We also had this issue on a previous 24TB device, but it seemed the issue there was with corrupted source files. Apparently not.

It seems that the Backup feature is not very robust, and when it fails - which seems to be a common occurrence - the problem can be very difficult to recover from, not to mention the loss of all the files actually involved. This is particularly troubling with a device intended as a (rather pricey) corporate backup solution.

- And now the tech got his answer, after 25 minutes. There is no other option. Create a second share, copy everything needed from the old share to the new one, and delete the old share with the damaged content.

Of course, since the UI does not allow folder copying between shares, this will have to be done from a network computer - routing all copy traffic through the computer, at maximum 1Gb rather than 3Gb.

He says he is "escalating" the issue, but considering is has been a "known issue" for five months, I'm not hopeful.


Buffalo: Be advised that we are a reseller, that this issue involves a government client, and that I will be posting this info on several social media outlets. If you resolve it in a timely manner, I will also post that information.
: Re: Cannot delete files created using Backup Utility
: fenrirGrey May 01, 2014, 02:46:57 PM
I was able to delete the files using FTP. That might be something you could look into if you are just looking to delete the failed backup.

But yes, I couldnt figure out a way around moving files via a network computer.

Also, in my case, the backup utility was timing out on large (2GB+) files. Hope it helps...
: Re: Cannot delete files created using Backup Utility
: Net7 May 03, 2014, 12:56:57 AM
AFAIK, since Buffalo does not give out Root access (/sadface), you must delete the ROOT level folder (IE the main folder under shared folders where you selected for the backup job), its not fun, and I have read of horror story's about days of copying files to a NEW ROOT level folder in order to get rid of them...

From what I read cringed about, it seems the Backup and Replication process (TeraStation only), uses the root user or a root level account to PREcreate both the files/folders (padding?) and locks them for its exclusive use, then starts the procedure! The issue it seems here is that if the Backup/Replication error's out, or is interrupted by anything other then what is considered NORMAL operation (completion?), while the process stops, the lock by the root/root level user is not removed... thus making deleting/removing files/folders that did not copy successfully an operation you "dont have access" to do...

Along with my other big want (an empty folder/s trashbox option in the WebGUI), I wish they would put a "ReAlign Permissions" button on the shared folders page, so if something like this occurs, you could simply use the button to remove the root permissions (since, ya know, you AREN'T root) and restore whatever access restrictions you have setup on the shared folder! Of course there would have to be other checks to make sure a backup/replication procedure isnt running, but this would solve this issue outright! (not to mention strip pesky NTFS permissions that sometimes manage to "inflitrate" when you copy it to the LINUX XFS/EXT3 partitions!)

Hope this helps your issue.
: Re: Cannot delete files created using Backup Utility
: fenrirGrey May 04, 2014, 06:44:22 PM
Considering the number of complaints about this issue and five months since no official response on this, I doubt they care what their consumers want. Personally, I'm never buying or recommending a Buffalo product.

Also, WTH is with the ridiculous questionnaire to "reply" to a forum post?
: Re: Cannot delete files created using Backup Utility
: MWPollard June 10, 2014, 08:32:41 AM
As noted above, we are a reseller. We are evaluating other options, since Buffalo has been failing us in dramatic ways the past few years.

When a network storage device intended for SMB backups regularly corrupts those backups, even when backing up between identical devices from the same manufacturer, and all without either notice or recoverability, it's time to look elsewhere.
: Re: Cannot delete files created using Backup Utility
: fa2lerror March 29, 2017, 02:41:19 PM
Extremely unhappy. called tech support. after 1.5hrs  of being disconnected/hung up and endless queues. got no live person.

It is March 29 2017. This issue still plagues. I am also a reseller who sold many of these to clients. Now all the systems are full with no easy way to repair. Purchasing more hardware or USB drives to move data to make shift a solution isnt viable. If purchase was an option,  the time to moving 48TB to alternate drives and back isnt. I dont have 3+ weeks.

Buffalo is officially off my companies vendor lists. I found the price and iSCSI attactive along with VMWARE stamp of approvals.

I support 16x  TS3400, to many to count TS5400.

Time to go back to Seagate Black Armor systems and seriously evaluate FreeNAS as solutions.
: Re: Cannot delete files created using Backup Utility
: Eastmarch April 07, 2017, 02:56:40 PM
This is a 3 year old thread - this shouldn't be happening on current firmware.

Support also has minimal queues.

PM me the number you are calling.
: Re: Cannot delete files created using Backup Utility
: tginsandiego February 24, 2019, 07:01:50 PM
So apparently nothing has changed after FOUR years of people complaining about this.

The backup jobs still create folders with ROOT owner, so although I can empty them of the files from backups deemed redundant or unnecessary, I cannot delete the highest level folders.

I have tried every option I know to change ownership, or add additional users with access, but nothing works that allows me to delete the folder.  So frustrating.

I was going to insert a snapshot showing the ownership issue, but can't figure out how to add/include an image.  :(

Device:  LS220D 
: Re: Cannot delete files created using Backup Utility
: shinkat August 12, 2019, 11:22:21 PM
A possible solution I found in a Japanese site said to turn off AFP (Shared folder / LAN protocol support). When I try to delete the backup files from my Mac with smb, I was able to delete few files at a time, but could not delete group of files (i.e., a folder). However, if I use FileBrowser app on my iPhone, I was able to delete the files. May be I should have used Windows Explorer or Linux.