Buffalo Forums

Products => Storage => : Sethusoid September 13, 2013, 03:17:44 PM

: TS5400D1604 Factory Reset
: Sethusoid September 13, 2013, 03:17:44 PM
I am trying to reset a Terastation TS5400D1604 completely to factory settings.  Unfortunately, I have forgotten the admin password and I'm having no luck resetting it.  I do NOT have a USB reset stick made nor can I make one since I can't log into the device without the admin password.  I've also tried holding in the red button inside the door both while on and while turning on, and this seems to have reset the dhcp status as I now can see the device on the network and I couldn't before.  Is there no easy way to reset the password on this device?  I do not care about any of the data on the device as it is all backed up.  I can't find very much info about this device either such as putting it into EM mode etc.  Any help here is appreciated.
: Re: TS5400D1604 Factory Reset
: davo September 13, 2013, 03:43:17 PM
Not easy but bare with me:

Connect a keyboard to the USB2 ports, connect a monitor to the vga port.

Boot the unit up, after (exactly) 60 seconds you will be presented with 4 options:
1.RAMroot 2? sda1 3......
As soon as you see these option press 1 and enter on the keyboard and let the unit boot, after a couple of minutes you should see the screen go red and the Nas Navigator will say it is in EM Mode.

Once it is in this state, download the latest firmware (2.42 i think), unzip the firmware and disable any AV and firewall software.

Right click the TSupdater.ini file -> Edit and it will open notepad.

Noformatting=1 (change the 1 to 0)
Debug=1 (Change the 1 to 0)

Exit and save the file.

Open the TSupdater.exe file -> Right click the title bar -> Debug.
On the right hand side tick "force update" and "delete user data partition" (the latter option doesnt touch the data but resets the admin password.

Click OK -> Update and proceed with the update as normal.

Let me know if it works.
: Re: TS5400D1604 Factory Reset
: Sethusoid September 16, 2013, 10:55:11 AM
I am not seeing the menu you mentioned.  I get a grub menu but never see a menu with "1. HDDroot" or anything like that.  I tried to run the updater in debug mode, selecting the correct options you mentioned, but it asks for the admin password, I'm guessing because the unit is not in EM mode.  Is there another way to place this unit in EM mode?
: Re: TS5400D1604 Factory Reset
: davo September 16, 2013, 11:17:22 AM
This is the line you need to look out for:


: Re: TS5400D1604 Factory Reset
: Sethusoid September 16, 2013, 11:33:43 AM
Ok, got it now.  That menu goes by fast.  I now have a factory reset TS5400!  Thank you very much for your help Davo!