Buffalo Forums

Products => Storage => : alan_gen April 08, 2009, 02:52:59 AM

: Drivestation NTFS NAS issues
: alan_gen April 08, 2009, 02:52:59 AM

Thanks to anyone in advance who can offer help...


I have DriveStation FlexNet HD-CE1.0TLU2 (1TB USB/NAS drive) which I am having a lot of difficulty installing.


First: I started using it in USB mode so that I can quickly backup my data. However, in doing so, I used Windows Disk Manager to reformat the drive to NTFS so I can copy >4G files.


Looks like that was a bad move. Problems galore:


1) Initially I was able to copy a lot of stuff on to it from my main laptop but now it simply will not register as a USB drive anymore...the XP balloon pops up that new hardware is detected but I don't see a new drive under "My Computer". However it works on another older laptop - no problem.


2) I hooked up the drive to my router; after installing the Buffalo program, using the BrowseHD-XXXX shortcut, it asks me for a password, which I do not have.


3) I looked up the DS IP address from my router admin page. Going to \\IP does not work -- I am asked for a username / password. "admin/password" does not work.


I did (2) and (3) above with my old laptop that "see" the drive using USB.


Reading some notes on this forum shows that in formating the drive to NTFS, I have deleted a crucial Share folder, so IP access (NAS) will not work. Is that true? I do I correct? I ***REALLY*** cannot reformat the drive to FAT32 because a) I need NTFS, b) I have a lot of stuff on here now which I don't know where to put anymore!


Finally, on a slightly humorous note, I tried to download support software from buffalo's website. It asks me for a SERIAL number. At the bottom of the drive, I can find 2 numbers starting with: MEMBUFFXXXX and 455----. Neither of these work.


I am not a complete dunce when it comes to electronics but I fail to see how I can recover having apparently committed some cardinal sins in setting this up. Help? :)


PS: I have tried the support line but been on it for >1 hour at various times to no avail. Just music.


To summarize: I'd like to find out:

a) Why the external drive as USB is not showing up on my new laptop (the port is OK, I checked) -- I read somewhere that sometimes it gets confused so a few reboots are needed - tried that, no avail. Pressed "reset" button. No avail again.

b)  Why is ethernet access (\\IP) askng for username / password? I don't think I set it up but even if I did, how can I reset?


Message Edited by alan_gen on 04-08-2009 02:58 AM
: Re: Drivestation NTFS NAS issues
: JoshC April 08, 2009, 11:34:50 AM

First off there is no username/password for that model.  You can only keep the format at fat32 becuase if you use NTFS it will as for permissions, fat32 does not rec. permissons.  Also you dont have to use the MEMEO software you can use any backup software that you choose if you are still having a problem with the key and (yes it will start with MEMBUFF) it wont work give us a call and we can fix that issue.



Reading some notes on this forum shows that in formating thedrive to NTFS, I have deleted a crucial Share folder, so IP access(NAS) will not work. Is that true? I do I correct? I ***REALLY***cannot reformat the drive to FAT32 because a) I need NTFS, b) I have alot of stuff on here now which I don't know where to put anymore!    CORRECT!


: Re: Drivestation NTFS NAS issues
: alan_gen April 09, 2009, 01:44:43 AM

1) Thanks, JoshC for the response...much appreciated. Your sentence did not come out complete - can you restate: "You can only keep the format at fat32 becuase if you use NTFS it will as for permissions.."?


2) I don't care about using MEMEO software. But I do need ethernet access -- after all, that is the reason why I got this drivestation. Now that I have some data on here and it is in NTFS format what are my choices? I don't want to delete the data but if necessary to reformat to get ethernet access, I will do so. Please help me understand how I can revert to a state where IP access is feasible.


3) Also, I undersand your point that no username/password are required -- but then why does going to \\ (the DriveStation's IP address on my router) ask me for username/password?  



: Re: Drivestation NTFS NAS issues
: davo April 09, 2009, 05:40:55 AM
   In a nutshell, if you reformat the drive to NTFS you lose all the NAS / LAN capabilites.
: Re: Drivestation NTFS NAS issues
: JoshC April 09, 2009, 11:03:06 AM
Correct and also when I say Permissions I mean when you were trying to access your drive station it was asking for a username and password.  That will only happen when you format it to NTFS.
: Re: Drivestation NTFS NAS issues
: alan_gen April 09, 2009, 05:07:00 PM

I have created some original videos for DVD creation that fall at 5G / file so I definitely need this NTFS storage.


For 90% of my other work, FAT32 is OK so I can have ethernet based access & backup to my laptops.


Here's an idea: As a work around to the NTFS / NAS constraint, can I partition the drive into NTFS and FAT32 and expect that the FAT32 drive will have NAS capability? 


(BTW, guys, really appreciate your help on this) -- Thanks.  

: Re: Drivestation NTFS NAS issues
: Dustrega April 09, 2009, 06:14:11 PM
Unfortunately, reformatting this device into NTFS will eliminate it's NAS function. I would recommend keeping the device in FAT32.
: Re: Drivestation NTFS NAS issues
: jclothi April 25, 2009, 01:22:09 PM
   RE: HD-CE1.0TLU2. Is there a 3rd party software utility that will manage this product? Apparently there is factory software on the drive that was supposed to make it function as a network drive? And this software gets destroyed when you format the drive? Apparently it was factory formatted to a  non-functional FAT32 format, so when you reformat it NTFS to at least get it to work as a  USB drive, you the lose the NAS operating software. Then you find out that it should be restored to FAT32. So you try to reformat to FAT32 but it is too late... cant be reformatted from NFTS TO FAT32 . The failed formatting leaves a drive that cant be accessed either USB or LAN.
: Re: Drivestation NTFS NAS issues
: Colin137 April 25, 2009, 01:30:49 PM

jclothi: Not quite.


The Drivestation Flexnet needs to use FAT32 for the filesystem, since Linux NTFS write support has not been determined to be stable enough for use on our devices. FAT32 is the only filesystem that is well-supported by Windows, Mac OSX, and Linux, hence the NAS mode will only with when the drive is formatted with FAT32.


Formatting the device to NTFS will not destroy the operating system for LAN/NAS mode, but it will prevent file access via Windows File and Print Sharing (SMB). You should still have access to the web interface. Follow these steps to reformat to FAT32 (this will erase all data), and restore the NAS functionality:

  1. Switch the drive to USB mode and attach it to the computer.
  2. In Windows Disk Manager (Start->Run, diskmgmt.msc) – DELETE THE NTFS PARTITION on theFlexNet's drive. Note that this will delete any data on the drive, so make sure you're choosing the correct one! The drive should now show asUnallocated Space
  3. Shut down the DS Flexnet.
  4. Reboot the DS Flexnet. After it’s had 30 seconds to spin up,push the button on the front to switch it to LAN mode (the light on thefront should be green once the button is pressed).
  5. Run the DriveNavi.exe on the installation CD.  Click on “Options” at the bottom of the screen, and then “Browse Setup Page.”
  6. A browser should open up and the web interface for the FlexNetshould load. If it doesn’t, go back to the Drive Navi tool and clickthe “View Information” button there to find the LinkStation’s IPaddress and connect manually with a browser.
  7. In the Web Interface, click on Disk Management on the leftcolumn, then “Format Disk.” This will restore the original FAT32partition to the drive as well as the Share folder that it needs to benetwork-accessible.


Message Edited by Colin137 on 04-25-2009 01:33 PM
: Re: Drivestation NTFS NAS issues
: jclothi April 26, 2009, 04:19:49 PM


Thanks for your reply but I cant get past steps 6/7. Message is "Cant Find...Check Cable:

Tried several LAN cables and several hubs. Hub green light wont come on. I must have fried the on-disk software.


Can you give me a phone number at Buffalo for a return? I will gladly pay for a repair or exchange, including shipping, of the HD-CE1.0TLU2.

: Re: Drivestation NTFS NAS issues
: Colin137 April 27, 2009, 04:30:48 PM
Make sure you have firewalls disabled on the computer, and try finding it again. If that doesn't work, call our US support line at (866) 752-6210 to troubleshoot a bit more, and if we can't get it working, we'll set up an RMA for you.
Message Edited by Colin137 on 04-27-2009 04:31 PM
: Re: Drivestation NTFS NAS issues
: Osotaino May 29, 2009, 09:58:36 PM

Hi there Colin! 


I followed your instructions and I get the IP address on the browser but it still requests a username and password. any sugestions after that?




: Re: Drivestation NTFS NAS issues
: Dustrega May 31, 2009, 04:58:25 AM
Did you try the defaults of admin/password when attempting access to the web admin?
: Re: Drivestation NTFS NAS issues
: Osotaino May 31, 2009, 12:03:58 PM

I did try those. even the variation that some companies seems to like. 

no luck.


: Re: Drivestation NTFS NAS issues
: JoshC May 31, 2009, 02:49:13 PM
If you set the unit back to the FAT32 format then by default there is no username and password.
: Re: Drivestation NTFS NAS issues
: Osotaino May 31, 2009, 11:48:33 PM

I followed the instructions provided here and it did not worked. 

But not to worry. after spending so much time on the phone with support. I just dumped the unit and got a maxtor one.  problem solved.  

: Re: Drivestation NTFS NAS issues
: dslinde June 18, 2009, 07:09:46 PM
   Was reading through the thread and I too have the same issues.  Did I read correctly that the OS for this drive is based on Linux?  And, that the issues with writing to this drive, after being formatted to NTFS, is due to limitations of Linux?  Then why not the option to format the drive to one of the very numerous formats that Linux handles natively, i.e. ext2fs, ext3, ReiserFS, etc...  That could be done through the web interface, and since it is supposed to be a NAS device, the type of file system should be transparent to the user.  Also, the ability to manage the drive through the web browser, other than what is there now, check the drive and format.
: Re: Drivestation NTFS NAS issues
: Dustrega June 20, 2009, 06:12:42 AM
Yes the operating kernel of these devices are Linux based and the data is written to a FAT32 filesystem to ensure maximum compatibility between Mac and PC users. Unfortunately, the format of these devices are not without their limitations and I understand your suggestions of formatting to a Linux based file system however then the compliant for a user to switch to USB and find "Where's my drive and why isn't it mounting" is a problem. It is a NAS and a USB device and hence the filesystem cannot be changed recklessly.
Message Edited by Dustrega on 06-20-2009 06:13 AM
: Re: Drivestation NTFS NAS issues
: European August 04, 2009, 06:24:52 PM

I am using the HD-CE1.0TLU2 as a backup device for my LS-XHL. Because the LS-XHL is formatted using an EXT filesystem by default, and the HD-CE1.0TLU2 is formatted as FAT32, I ran into trouble backing up very large files. So I decided to reformat the HD-CE1.0TLU2 with an EXT filesystem.


I believe that there are EXT fs drivers for Windows so that I could access it by USB, but I have not tried it. Does the LAN function support EXT?

: Re: Drivestation NTFS NAS issues
: glentz September 01, 2009, 09:59:20 PM



In LAN mode the flexnet can handle file sizes upto 127GB according to the manual. I have successfully copied files in the 5+GB range to the Flexnet while in LAN mode. So it appears FAT32 limits don't apply in LAN mode. However note that files >4gb that were copied to the flexnet while in lan mode won't be accesible via USB.


The one downfall to this is LAN mode takes at least 2x longer to move information onto or off of the drive compared to USB 2.0 mode. I also have networked/shared PC's (win9x and win xp's) and copying files from computer to computer over the same network is much faster compared to the flexnet or my older 120gb drivestation so I know my network is not at fault.


Someone also mentioned WD drives are used. Not always true, mine has a Samsung.


From the users manual


"With a LAN connection, the maximum file size is 127 GB. Files larger than 4
GB will not be accessable from the USB interface.

With a USB connection, the maximum file size is 4 GB."


Greg Lentz (Home user)

: Re: Drivestation NTFS NAS issues
: Colin137 September 01, 2009, 10:11:02 PM
You'll notice that if you transfer a file larger than 4 gb to the Flexnet in LAN mode, it will split the file into ~4GB chunks. This is due to the filesystem limitation. Trying to access files that have been split from USB will not work.
: Re: Drivestation NTFS NAS issues
: prometheus May 17, 2010, 12:38:51 PM

Hi Alan,

I have the same drive that you mention running on my work server win2003 (what Baffalo fail to mention to people when they install their untis) in reformatting the drive to NTFS from Fat32-there are files/folders preinstall on units (this is where the data needed to have install on laps/PC when first use). If you reformat drive brfore either saving these files/folders to flash drive or some other drive on local lap/PC-then they are wiped out. Also going to a newer laptop from older (if thisngs still work as normal when put BACK on older PC), the same version of Windows has to be the same down to the letter ( XP1, XP2 or XP3 and sor forth) if your new laptop is slightly different from what is on your older PC??/ the unit will not work (like trying to run your windows apps on a MAC-it won't work exactly the same). See I went from win serer 2003 to winXP2 sp3 and my unit stopped working when I put it on the XP2;sp3 PC, but works when I put back on the server 2003 PC. Even when you look at the box information about installing and compatability with XP,Vista, server 2003, it really isn't if going accross different platforms. Once you install on one platform, but later have to move to different one you would need to install all over again (providing the files/folder aren't wipe out when formatted to NTFS). Make since? just another POV