Buffalo Forums

Products => Solved Storage Threads => : AdamH January 01, 2009, 05:48:14 PM

: Semaphore Timeout Error
: AdamH January 01, 2009, 05:48:14 PM

Issue: When copying files WIRELESSLY from my local laptop to my LinkStation it fails due to an error (Error 0x80070079: The semaphore timeout period has expired." 


Background Context:  This error happens whenever I attempt to copy a single large file (video .mp4) or a batch of small files (copying a folder of pictures .jpg).  Sometimes, but not always, the error is followed by a crash in Windows Explorer (the program I use to transfer the files).   In addition, sometimes, but not always, the error causes a crash in my network such that I lose local and internet network function.   This only happens with a wireless transfer of files onto the LinkStation.



Computer: Toshiba Satellite laptop (model #: A135-S4427)

OS: Vista Home Premium (SP1)

Buffalo Product: LinkStation Live (model #: HS-DH1000GL)  Firmware: v. 2.10 

Wireless Router: Linksys Wireless-G (model #: WRT54GS) 


I've done some searching on the internet and haven't found a huge amount of satisfactory fixes for this error.  It seems it could be a router issue.  It seems to happen on Vista. I know the Buffalo drives have some issue working on Vista.  Is this one of those issues such that I need to download or edit the registry that Buffalo recommends in one of their knowledge base articles (KB#000001)? 


Thank you.  

: Re: Semaphore Timeout Error
: AdamH January 02, 2009, 12:18:03 AM
   Please disregard the last post.  It appears that a firmware upgrade to my wireless router has resolved the issue even though I have no idea what was causing the problem. 
: Re: Semaphore Timeout Error
: 13thmonkey April 09, 2009, 02:35:11 PM

Well, i've hit the same problem on a linkstation live with bittorrent, transferring large files by wired connection is fine, but doing it via wireless is not, it always stalls after about 10-15sec, roughly 40MB.


I'm using a dell 1330, all patched to latest vista 32bit.

linkstation has firmware 1.07 and used the 1.03 CD, so I assume I have everything to the latest spec.


Any thoughts or help?


: Re: Semaphore Timeout Error
: Dustrega April 09, 2009, 07:16:01 PM
Which ports have you forwarded to the LinkStation thus far? I'm sorry I just didn't notice that in your post.
: Re: Semaphore Timeout Error
: 13thmonkey April 10, 2009, 03:52:30 AM

I just used the standard software setup, windows firewall was off during the setup. My desktop works fine (vista 64bit, wired connections), its just my laptop (vista 32bit) on wireless (802.11g), wired is fine.


Where do I check for forwarded ports, windows firewall or the router firewall.


Havng just checked the router firewall settings there are no inbound or outbound ports setup. Windows firewall reports that that buffalo NAS navigator 2 is an exceptioned program.


Hope this helps, is there a sticky on this topic I should be looking at?

: Re: Semaphore Timeout Error
: Dustrega April 10, 2009, 06:57:28 PM
I'm sorry disregard the last post about the ports. When you mention the bittorrent client I automatically thought that you were talking about the transfer of torrents not from your computer to the NAS and vice versa. When you're accessing the NAS are you accessing it by IP address?
: Re: Semaphore Timeout Error
: 13thmonkey April 11, 2009, 03:11:27 AM

I was accessing it via a mapped drive, it always seemed more responsive on deleting when access through the desktop shortcut that comes out at the device root, showing me the shared folder, the printers, info and LP, this might be more akin to the ip address.


However last night I had a bit of a breakthrough, I'd always suspected that it might be jumbo frames related (no idea why, something I read something about several years ago), and finally found the settings, and hey presto i've been able to copy large files, in the network settings of the admin page i've set ethernet frame size to 9,694 bytes. So far three large files (up to 400MB) no problem, previously all attempts failed at 10-15% or so.


So I think its fixed, and it should be a known repeatable fix, in fact it should be the default settings?  

: Re: Semaphore Timeout Error
: Dustrega April 11, 2009, 02:00:49 PM
Gratz on getting the problem solved :D
: Re: Semaphore Timeout Error
: 13thmonkey April 11, 2009, 02:40:48 PM
   do you have stickies on this forum, or a FAQ, seems to me it would be a common issue, and semaphore timeouts give 1000's of responses on google dating back to 2005 and earlier all solving, or typically failing to solve related but different issues, and nowadays having large files is very common.
: Re: Semaphore Timeout Error
: Colin137 April 11, 2009, 04:22:50 PM
Jumbo Frames typically only work right when all the computers on the network are using them too. It's not the default setting because the standard Ethernet MTU is 1500.
: Re: Semaphore Timeout Error
: 13thmonkey April 12, 2009, 06:59:38 AM
   I've not seen any settings for jumbo frames elsewhere, could this be the cause of only getting 30% of my 802.11g connection? about 2MB/s even when no-one else is switched on the network? Incidentally I was getting that same 30% whilst it was not working properly up to the point that it stalled and I lost network connection.