Buffalo Forums

Products => Solved Storage Threads => : EXP10 January 14, 2009, 09:00:22 PM

: FTP Address needed
: EXP10 January 14, 2009, 09:00:22 PM
   How can I figure out what my FTP address is to use with a FTP program.† I think I have everything set up on my router which is a WRT54gs and my LS 1000gl so it my be access from a FTP program. I can get it to work with the FTP program and just using firefox web browser from my house. I can not access it from my brothers house. The program I am using is FTP Surfer. I have added the port forward. I just don't know what address to give out so it my be access from friends and family.
: Re: FTP Address needed
: TroyWolf January 14, 2009, 09:35:25 PM

You need to find your "public IP Address". I could tell you that you can log into your Linksys router, go to the Status tab, and see your public IP. However, it's easier to just open your browser and go to http://www.whatismyip.com. You can then just FTP to that address.†

: Re: FTP Address needed
: EXP10 January 14, 2009, 09:43:31 PM
   My router ip that was explained how to get to is different then the ip that the website gave me.
: Re: FTP Address needed
: TroyWolf January 14, 2009, 09:50:01 PM
   Oh well...in any case, when you browse to www.whatismyip.com -- that is what your network appears as on the public Internet. You use that address to reach your router from the Internet.
: Re: FTP Address needed
: EXP10 January 14, 2009, 10:00:12 PM
   OK but I am a noob on this FTP stuff so please bare with me. OK I have that address. Now how does that address get connected to my NAS. I know what the IP of my public and the router and the NAS.† Could you give me a example of what the numbers might look like if I type them out. Again I am sorry this is new to me......just trying to share pictures and movies with family from out of state.
: Re: FTP Address needed
: EXP10 January 15, 2009, 01:09:26 PM
   I think my Public IP address is not allowing a FTP access. My FTP program will not connect. I have a modem connected to my router. Do I need to set up anything in my modem to make the LS1000GL work from my router?
: Re: FTP Address needed
: TroyWolf January 15, 2009, 01:40:33 PM

No problem--we were all noobs at one point.

First, you mentioned earlier that the IP Address you saw in your Linksys WRT54GL router's Status page did not match the IP you saw when you visited http://www.whatismyip.com. This concerns me. Let's make sure we are on the same page.

Log into your Linksys router. Click "Status", which is at the top right. About halfway down the status screen is "IP Address:". † If that IP Address does not match what you see at whatismyip, then your ISP has you behind another private network. I don't expect you to post your "public IP" here in the forum, but does your router report an address in one of these ranges?

10.* †(e.g.,, etc.)

192.168.* †(e.g., etc.)

I am a RoadRunner customer via TimeWarner cable. The IP Address they serve me is a real, public Internet IP. The IP Address in my router matches what I see when I go to whatismyip.com. This allows me to route to that IP and hit my router. It sounds like you may not be so lucky.†

: Re: FTP Address needed
: thanos2001 January 15, 2009, 01:44:52 PM

I'm having problems reaching my NAS remotely via FTP or Web access also. I've been able to do both locally. I called tech support and opened TCP ports 21 and 20 on my router. The technician wasn't able to try accessing because she was on a proxy server. I don't know why that would matter, but the issue remains.

How does the Buffalo NAS use the router's†ip address? Do I need make the NAS ip address public outside of the router somehow? Is there more detailed discussion on this topic? This is the first FTP thread I've come accross, but I'm sure others have run into this issue.


: Re: FTP Address needed
: EXP10 January 15, 2009, 01:52:57 PM
   I just checked again. and my ip is the default for the router. I was able to access my modem ( never done that before ) my modem has the correct public IP in it but I think it some how changes it from the router. In my DCHP of my modem it has it set to my router default. I tried to access my Public IP from a FTP program and a web page. The web page wanted a password but all of mine didn't work. I think my ISP provider is blocking FTP. I just contacted them and there going to get back with me.
: Re: FTP Address needed
: TroyWolf January 15, 2009, 02:19:16 PM


I've seen your configuration before, I think. A customer had something like that with an old DSL provider. The "modem" itself had the public IP and used DHCP to supply an address to the internal router. Then your internal router uses DHCP to provide addresses to your local devices. So you end up behind 2 layers of private network to get to the public Internet. No problem really, but in order to direct web, ftp, etc traffic from the outside to one of your devices, you first need to ensure your modem is configured to allow the traffic to reach your Linksys router.

If you know how to log into your modem, perhaps you can figure out how to enable that. I doubt your ISP blocks it at their end, but of course that is possible. Many ISP's have policies against running "services", but most don't really seem to enforce it as more and more peer-to-peer apps are really servers AND clients at the same time.†

: Re: FTP Address needed
: EXP10 January 15, 2009, 02:24:02 PM
   I have been fooling around with my modem changing port word working with DMZ tring a few other things with no luck yet. I am taking a break..........lol My eyes hurt. I have been trying this for a few days now. But I look at it this way I am learning something and I am thinking of going back to school for this type of feild. Thanks for your help. I hope my ISP might give me some help on how to config the modem since they supplied it.
: Re: FTP Address needed
: TroyWolf January 15, 2009, 02:31:01 PM


I will try to keep this simple...I tend to write books. If your situation is typical, you have a "modem" (cable/DSL, etc.) and you have a router. Wired or wireless makes no difference.

Typically, you use a "private" network (also called a private address range) inside your home. For example, on a Linksys router, I think it defaults to using 192.168.1.* addresses. (It is that or 192.168.0.*).

Your ISP will provide you a single public IP address. Typically, this address becomes the external address of your router. †It is the address that can be used from the Internet to route to your network.

If you want to host services, such as an FTP service on your NAS, you have to configure your router to point the traffic to the device. (The NAS does not need to know anything about the public IP.)

This is typically called "NAT" which stands for Network Address Translation or "Port Forwarding". In the Linksys router, the menu item is "Applications and Gaming". In it, you can tell your router that all TCP traffic on port 21 (FTP) should be directed to the IP Address of your NAS.

Once you enable this port forwarding, all normal FTP traffic from the internet to your public IP will be directed to your NAS.

: Re: FTP Address needed
: thanos2001 January 15, 2009, 07:46:51 PM

Thanks for the well crafted†response. It triggered the right brain cells and pointed me to my problem. I've got AT&T U-Verse and they are using a 2Wire Modem/Router combo that looks like a large landmine. AT&T's support†is useless.†The real trouble is router companies don't have a universal UI for firewall settings. I missed the dropdown that allowed me to select the NAS as the thing using the open ports. I was opening them for my PC instead.

Thanks again! I'm a very happy customer now.

: Re: FTP Address needed
: EXP10 January 16, 2009, 07:11:15 AM

OK I think I got it what I needed. My modem was not letting my public IP pass to my router. I still haven't figured out why. I tried all the port forwards and dzm.....no luck. I read up and decided bridged my modem to my router. If it didnít work itís ok I just hit the reset switch. The bridge went fine. I set my router up with my user name and pass word and connected. No issues things seem to work. I had to reboot since my internet stop working. I guess I needed to get assigned a new ip address from windows. I connected and now I can see my NAS from outside my network I think. I haven't had my family try it yet since there @ work. I used a ftp program and entered my public IP and it went right to my NAS. So I think it's working because it never did that before. Thanks for all the help TroyWolf. You made me think and I wouldnít have seen somethingís if you havenít told me about my IP address in my router.

: Re: FTP Address needed
: EXP10 January 16, 2009, 06:42:15 PM
   Just a update. My NAS is working fine from web and local. Thanks again for your help