Buffalo Forums

Products => Solved Storage Threads => : alambrec October 28, 2008, 11:15:19 PM

: Link Navigator can't find Linkstation Pro
: alambrec October 28, 2008, 11:15:19 PM

Not sure if this is one or multiple problems.


I have connected the Linkstation Pro (LS-500GL) to my wireless router (Linksys WRT-54G) and the link light comes on.


I am running vista business SP1. 


Link Navigator comes up with "Setup cannot be completed" "a Linkstation could not be found on the network".


Buffalo NAS Navigator cannot find anything.


However, I can navigate to the drive in Windows Explorer using the IP address -- \\ and I can move files to it.


And I can connect to the Web management interface by using the IP address.


I cannot establish an FTP or SSH connection to the device.


I have gone into my netowrk settings and made sure NETBIOS is enabled.


Is there something I am missing?


Thank you,



: Re: Link Navigator can't find Linkstation Pro
: Edin October 29, 2008, 09:45:36 AM
   I had similar problem.  Running laptop with Vista Business.  Installs OK, but could not use Navigator.  It gives white space and nothing on it.  It looks like my wireless driver or wireless hardware do not play well with Navigator. Red about it somewhere here.  Did not test this using cable, but since on laptop I only use wireless, there was no point for me to test cable.  Navigator works fine on XP Pro/cable, but I uninstalled it.  You do not really need to use Navigator to be able to use your drive.
Message Edited by Edin on 10-29-2008 10:47 AM
: Re: Link Navigator can't find Linkstation Pro
: davo October 29, 2008, 12:14:50 PM

Deactivate any AV or firewall software, the navigator requires broadcast packets in order to communicate correctly with the linkstation. Alot of AV / firewalls block this kind of communication and hense nothing will appear. If it does appear once the software is disabled then create a rule in whatever program is causing the problem.

PS Download the Nas Navigator2 from the buffalo website and use that. It has a better GUI than the one on the CD

: Re: Link Navigator can't find Linkstation Pro
: alambrec October 29, 2008, 09:26:11 PM

Edin and Davo,

Thank you both for your replies.  I had guessed that as long as I could navigate to it an map it, that I didn't really need the navigator.


I should have mentioned that I had disabled my firewall and AV.


I downloaded  NASNavigator2 as suggested and it sees the NAS fine.  I did get a notification from Windows Firewall, which shouldn't have been on.  Not sure how it keeps getting turned back on.


But everything seems to be working now.


Thank you again.


: Re: Link Navigator can't find Linkstation Pro
: pete711 December 19, 2008, 04:17:26 PM
   FYI - I had similar issues... problem was trying to use laptop connected wirelessly. Once I did a direct Wired LAN Connection, Navigator worked fine and so did Installation of Firmware (which was aborting on Vista).