Buffalo Forums

Products => Wireless => : labasus April 01, 2009, 04:04:23 PM

: WHR-G300N WAN DHCP faild
: labasus April 01, 2009, 04:04:23 PM

I've got WHR-G300N Ver.1.60 (R1.49/B1.09

Router reset settings was done before I begin.


It is second router with simular problem.


First router after 3 weeks just stop detect DHCP queues from provider via WAN port. Tech. support detect that was WAN port failure, not recoveravable problem and return me a new one.

Second router after cable connecting into the WAN port does not detect IP automatically from DHCP server,

        but after SETUP -> Check connectingit really detect IP from DHCP.


Question:  What's wrong with this router, maybe some firmware upgrade could be helpful? I have found nothing to upgrade, cause there is no new firmware versions yet.


Some suggestions?

: Re: WHR-G300N WAN DHCP faild
: Aveyer April 01, 2009, 04:20:21 PM
   DHCP for mine works fine but I set it to static most of the time. Are you sure your modem(or whatever is doing the DHCP) is configured properly?
: Re: WHR-G300N WAN DHCP faild
: labasus April 01, 2009, 04:29:50 PM
   If I have use an another router (like Dlink or Linksys) DHCP IP detection works fine....
: Re: WHR-G300N WAN DHCP faild
: Aveyer April 01, 2009, 05:33:32 PM
   Is it using Perform Easy Setup or DHCP as the IP aquisition option?
: Re: WHR-G300N WAN DHCP faild
: labasus April 02, 2009, 01:37:20 PM
   Internet/LAN -> Internet -> Method -> Aquire and IP Adress Automatically from DHCP server
: Re: WHR-G300N WAN DHCP faild
: Dustrega April 04, 2009, 06:30:04 PM
Who's your internet service provider? Did you power cycle your cable/DSL modem with it connected to the router?
: Re: WHR-G300N WAN DHCP faild
: labasus April 05, 2009, 02:53:46 PM

Internet provider is a TEO, Vilnius-Lithuania.

I have a Fiber optic converter at home, nothing special...


As I've said other wireless routers have no problems with IP detection via DHCP.

: Re: WHR-G300N WAN DHCP faild
: Colin137 April 18, 2009, 12:43:27 PM

That's quite strange... when you do get a DHCP lease (with a computer or something) from the internet provider, what are the first two numbers in the ip address? 192.168.x.x or similar? Also, what is the subnet mask?

: Re: WHR-G300N WAN DHCP faild
: labasus June 02, 2009, 08:38:48 AM
   I've got an external IP address from internet provider IP Address starting 78.60.xxx.xxx
: Re: WHR-G300N WAN DHCP faild
: elmoo March 20, 2010, 02:31:42 PM


I have same internet connection: Fiber optic -> TEO -> Vilnius, Lithuania

Router whr-g300nv2-eu firmware 1.70.


Router doesn't get IP address from provider, using DHCP.

I have tested router in other Internet Service Provider network, it gets IP very quickl via DHCP.

D-LINK works fine in TEO network, so why whr-g300nv2-eu has problems quiring IP ?

What could be the reason for that? any ideas?

: Re: WHR-G300N WAN DHCP faild
: Colin137 March 20, 2010, 04:42:21 PM

Hook up your computer directly to the cable modem via Ethernet. Confirm that it works, and you get a public IP address on the computer. Find out the Physical address of the ethernet port on the PC (in a command prompt, "ipconfig /all" without quotes, look for the Physical Address under Local Area Connection.


Hook up the router to the modem, log into the web interface, and in Internet/LAN, change the MAC Address of Internet port to the physical address you found for the computer. Make sure you replace the dashes with colons (01-23-45-67-89-AB becomes 01:23:45:67:89:AB), and enter it in.

: Re: WHR-G300N WAN DHCP faild
: elmoo March 21, 2010, 02:00:37 AM

Hello Collin,


I have connected the the cable direct to PC.

1.Cloned MAC address to the router with colons.

2. Entered all the addresses (IP, gateway, DNS) manually to the router.

3. Connected to the router via Wifi


5. For unknown reasons after an hour internet connection disappears.

6. Again plug in the ethernet cable to the directly to the PC to check the connections.

7. PC gets quickly the same address via dhcp.

8. Internet is accessible.

9. Plug in the cable back to the router 

10. Internet is working again.


Two main problems:


1) Why router doesn't get IP via dhcp?

If it is set to 'Acquire an IP Address Automatically from a DHCP Server' , the connection status is "Querying" all the time and nothing happens. Even if you trey "RELEASE -> RENEW " several times with timeouts between the actions.

It seems that router doesn't understand dhcp messages sent from the provider. 


2) If the IP address is set manually, anyway the connection is being lost after an hour and recovers only after :

    a) plugging the cable directly to the PC

    b) Enter any website to check the connection.

    c) put back ethernet cable to the router. 


Also it is strange that firmware version in section Admin config-> update->


WHR-G301N Ver.1.70


is different from diagnostic-> model -> WHR-G300N Ver.1.70 (R4.02/B1.00)


Does anyone else get the same problem? 




: Re: WHR-G300N WAN DHCP faild
: havito April 02, 2010, 05:50:25 AM

Anybody found solution for this problem? I  have WZR-HP-G300NH.  Internet provider is a TEO, Lithuania.  Router doesn't get IP address from provider, using DHCP. With dd-wrt firmware it`s ok, but with dd-wrt i can`t use torrent downloading.

: Re: WHR-G300N WAN DHCP faild
: bakanub April 07, 2010, 03:39:45 PM

just wanted to bump the thread as i have the same problem. with dd-wrt - dhcp works perfectly...

: Re: WHR-G300N WAN DHCP faild
: Big_Dog April 07, 2010, 07:25:02 PM

Same Problem - I use comcast.Takes about 5 to 10 minutes and many retries before I can  get an IP

: Re: WHR-G300N WAN DHCP faild
: elmoo April 08, 2010, 12:51:36 AM



What dd-wrt softare are you using?

can you please post the the direct link to the download?


As I have WHR-G300Nv2EU on www.dd-wrt.com site it is listed as not supported. is it true?


The main difference between WHR-G300Nv1 and WHR-G300Nv2 is the chipset. v1 uses RaLink and v2 uses Atheros7240.


Which chipset is in your router?

: Re: WHR-G300N WAN DHCP faild
: JoshC April 08, 2010, 03:12:22 AM

DD-WRT is not supported as of right now and it will VOID your warranty/support if you flash it on your unit.  You will need to go to the DD-WRT forums.

: Re: WHR-G300N WAN DHCP faild
: elmoo April 08, 2010, 11:11:55 AM

So what is suggested if original buffalo firmware always quering the IP address and doesn't get IP from ISP dhcp server? 


PC with the same MAC address with pluged Internet cable gets IP immediately. 



: Re: WHR-G300N WAN DHCP faild
: beprotis April 19, 2010, 06:11:33 AM

The same problem here.

It looks router stores address of DHCP server of former ISP, so you can not connect to DHCP server of the new one.  I reinitialized it several times and tried with three different ISP - it works only with the first one, so it is problem with firmware.

I have contacted ISP help desk. They said, the physical connection was ok, but they did not get my routers mac adress!

: Re: WHR-G300N WAN DHCP faild
: VeijoEsso May 27, 2010, 08:39:22 AM



We have a 100/5 cable modem connection and we are having the same problems - deffinately a firmware bug!


Hello buffalo are you fixing this? Download page does not show a firmware update.

: Re: WHR-G300N WAN DHCP faild
: CapnSmith June 11, 2010, 08:58:39 AM

Are your routers in Auto mode?  On the router there is a switch labeled "Auto/Off/On."  In the auto position, the router will try to auto detect your ISP.


If the router switch is in the "On" position, it could still be stuck in "Auto-detect" and you can follow these steps to correct it:

If the device is stuck in autodetect mode, even when the switch is on, or it doesn't accept the default username and password after a reset, try these steps, they worked for me.

: Re: WHR-G300N WAN DHCP faild
: dhgaut June 11, 2010, 05:02:15 PM

I posted elsewhere but it is worth repeating:  I purchased 9 WHR-G300N's from Provantage and 3 from Tech Data.  They are listed as model WHR-G300N-US on the box but when you click on diagnostic you can see them self-identified as WHR-G301N v.1.70 firmware.  The boxes work okay with Clear but they do not like the Comcast boxes.  I can get them to work for maybe an hour but as soon as I tapdance away, the boxes revert to "cannot obtain an IP address from DHCP".  I've tried to dongrade the boxes to v.1.65 but it rejects the firmware as invalid for the model.  The lost time and money on this is fast approaching $1,000 as I have to swap out the boxes with a different brand.  I called Buffalo for support but it was a COMPLETE WASTE OF TIME.  They have no knowledge of v.1.70 and think twiddling with the interface will fix it.  IT DOES NOT. It isn't simply an issue of setting the interface to DHCP only, or of changing the MAC address.  It may be they don't work with Motorola modems (Comcast uses many different models of Motorola).  As soon as DD-WRT has a working version for this model I will flash one and test it.  But I am going to take this as a big red flag to halt purchases of all Buffalo products.  They were once excellent but I believe this problem indicates a systemic failure within the company.